Profile column is missing data in Place Hold patron search results

Bug #1755892 reported by Jeff Davis on 2018-03-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Medium
Unassigned

Bug Description

EG 3.0.3

In the web client:

1. Do a catalog search or retrieve a record.
2. Click Place Hold.
3. On the place hold screen, click Patron Search.
4. Search for patrons (e.g. last name = "smith"). In the results grid, the Profile column is empty. It should, of course, contain the patron's profile.

This problem does not exist in the main patron search interface (Search > Search for Patrons), only in the Place Hold patron search UI. I note that the two patron search interfaces are using different templates.

tags: added: webstaffclient webstaffcolumns
Jeff Davis (jdavis-sitka) wrote :

The profile column is empty in place hold patron search results because the profile column isn't being fleshed properly. Here's a fix:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jeffdavis/lp1755892-place-hold-patron-search-profile

tags: added: pullrequest
Galen Charlton (gmc) wrote :

Signoff branch here: user/gmcharlt/lp1755892_signoff

tags: added: signedoff
Changed in evergreen:
importance: Undecided → Medium
status: New → Confirmed
Bill Erickson (berick) wrote :

Issue and fix confirmed. Thanks Jeff and Galen. Merged to master and rel_3_0.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
assignee: Bill Erickson (berick) → nobody
milestone: none → 3.1-rc
no longer affects: evergreen/3.1
Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers