URI call numbers show up on Holdings View

Bug #1752665 reported by tji@sitka.bclibraries.ca on 2018-03-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.1
Medium
Unassigned

Bug Description

Evergreen 3.0.3

Call numbers for located URI show up on Holdings View. They can be deleted, but the corresponding 856$9 remains in MARC. Editing the bib record re-creates the URI call number.

To test, find a bib with 2 856 tags and two URI call numbers.
Delete one call number.
Search for the title, you will see the link is gone.
Edit the bib. Search again. Check Holdings View. The link and the call number are back.

Tina Ji
BC Libraries Coop

Jeff Davis (jdavis-sitka) wrote :

This issue is more obvious in EG 3.1.4+ due to the fixes for Holdings View from bug 1773417. Located URIs now show up as volumes whenever "Show empty volumes" is checked.

Located URIs should be hidden in Holdings View to prevent them from being directly modified.

Changed in evergreen:
status: New → Confirmed
milestone: none → 3.1.5
Jeff Davis (jdavis-sitka) wrote :

Working branch user/jeffdavis/lp1752665-uris-holdings-view has a simple fix:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=b6ff248e

The fix omits volumes with label '##URI##' when retrieving holdings in Holdings View.

tags: added: pullrequest
Changed in evergreen:
milestone: 3.1.5 → 3.1.6
Changed in evergreen:
milestone: 3.1.6 → 3.2.1
Changed in evergreen:
milestone: 3.2.1 → 3.2.2
Changed in evergreen:
milestone: 3.2.2 → 3.2.3
Jane Sandberg (sandbej) on 2018-12-05
tags: added: cataloging
Changed in evergreen:
status: Confirmed → New
milestone: 3.2.3 → 3.3-beta1
Galen Charlton (gmc) on 2019-02-18
Changed in evergreen:
status: New → Confirmed
milestone: 3.3-beta1 → 3.2.4
no longer affects: evergreen/3.2
Changed in evergreen:
importance: Undecided → Medium
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Tested and fix pushed to master, rel_3_2, and rel_3_1. Thanks, Jeff!

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers