Reporter doesn't load in web client

Bug #1751520 reported by Jason Boyer on 2018-02-24
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.0
High
Unassigned

Bug Description

Eg rel_3_0 as of 2018-02-24

It's not possible to load the reporter in the web client on the current rel_3_0 (I've not yet checked master, but assume it's the same there). I've removed my assumption of the cause because the effect was caused by my experimenting trying to get things to work, there's nothing logged on the server side, but this is in the JS Console:

Uncaught Error: [$injector:modulerr] http://errors.angularjs.org/1.5.11/$injector/modulerr?p0=egReporter&p1=Error: [$injector:modulerr] http://errors.angularjs.org/1.5.11/$injector/modulerr?p0=treeControl&p1=Error: [$injector:modulerr] http://errors.angularjs.org/1.5.11/$injector/modulerr?p0=contextMenu&p1=Error: [$injector:nomod] http://errors.angularjs.org/1.5.11/$injector/nomod?p0=contextMenu...
    at angular.js:38
    at angular.js:4692
    at q (angular.js:325)
    at g (angular.js:4653)
    at fb (angular.js:4575)
    at c (angular.js:1809)
    at Gc (angular.js:1830)
    at se (angular.js:1715)
    at HTMLDocument.<anonymous> (angular.js:32616)
    at i (jquery.min.js:formatted:1308)
(anonymous) @ angular.js:38
(anonymous) @ angular.js:4692
q @ angular.js:325
g @ angular.js:4653
fb @ angular.js:4575
c @ angular.js:1809
Gc @ angular.js:1830
se @ angular.js:1715
(anonymous) @ angular.js:32616
i @ jquery.min.js:formatted:1308
fireWith @ jquery.min.js:formatted:1362
ready @ jquery.min.js:formatted:1456
J @ jquery.min.js:formatted:1464

Other eg-embed-frame interfaces are loading properly.

Jason Boyer (jboyer) on 2018-02-24
Changed in evergreen:
importance: Undecided → High
milestone: none → 3.0.4
Jason Boyer (jboyer) on 2018-02-26
description: updated
description: updated
Jason Boyer (jboyer) on 2018-02-26
description: updated
Jason Boyer (jboyer) on 2018-02-26
Changed in evergreen:
milestone: 3.0.4 → none
Kathy Lussier (klussier) wrote :

I'm also seeing it on master. I see the error JBoyer noted in the Console, but I see this at the top of the log:

Uncaught Error: [$injector:modulerr] Failed to instantiate module egReporter due to:
Error: [$injector:modulerr] Failed to instantiate module treeControl due to:
Error: [$injector:modulerr] Failed to instantiate module contextMenu due to:
Error: [$injector:nomod] Module 'contextMenu' is not available! You either misspelled the module name or forgot to load it. If registering a module ensure that you specify the dependencies as the second argument.

Changed in evergreen:
status: New → Confirmed
Mike Rylander (mrylander) wrote :

Looks like the tree control we're using there was magically updated out of compatibility with the older version we were using ... or it just went missing. A master-ish branch that

 1) hasn't been updated with the new WebPack stuff and
 2) hasn't had the Angular stuff updated in a couple months

is working fine. :(

Jason Boyer (jboyer) wrote :

Branch(es)!

Since we're changing how the JS is processed in 3.1 there needs to be a separate branch for master and rel_3_0.

master / rel_3_1: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1751520-tree-context

rel_3_0: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1751520-tree-context-rel_3_0

I've tested rel_3_0 but can't test master for a few days so if anyone else has time to verify it works I would appreciate it.

tags: added: pullrequest
Jason Boyer (jboyer) on 2018-02-27
summary: - Reporter doesn't load in rel_3_0 web client
+ Reporter doesn't load in web client
Galen Charlton (gmc) on 2018-03-02
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

I've pushed two signoff branches:

user/gmcharlt/lp1751520_signoff_master
user/gmcharlt/lp1751520_signoff_3_0

Note that the one for master includes a follow-up accounting for how Webpack needs to pick up context-menu.js. I suspect that the need for explicitly referencing context-menu.js may go away in future releases of angular-tree-control depending on how its maintainer responds to issue reports.

tags: added: signedoff
Changed in evergreen:
milestone: none → 3.1-beta
Galen Charlton (gmc) on 2018-03-02
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Dan Wells (dbw2) wrote :

Pushed appropriate branches to master and rel_3_0. Thanks, Jason and Galen!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers