Web client: Check-in deleted item from patron account

Bug #1751368 reported by Blake GH on 2018-02-23
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Medium
Unassigned

Bug Description

EG 3.0.2
Webby

Sometimes an item gets deleted without first clearing the patron account. This results in a deleted checked-out item. You can no longer check the item in because the barcode doesn't exist. However, you could open the patron account and check the item in from the "Items Out" screen using the XUL client. This is achieved by referring to asset.copy.id instead of asset.copy.barcode.

The web based staff client does not allow this behavior and it should.

Blake GH (bmagic) on 2018-02-23
tags: added: webstaffclient
Michele Morgan (mmorgan) wrote :

Certainly this is a change in behavior from the xul client, and makes it impossible to check in an item that is still checked out when deleted.

However, any fix for this should avoid existing behavior in the xul client when a checked out deleted item and active item both exist with the same barcode. In the xul client, showing item details for the deleted item in actuality retrieves the active item since the lookup is done by barcode.

John Amundson (jamundson) wrote :

Confirmed this is happening on 3.0.8 web client.

Item can still be checked in from the XUL client.

Changed in evergreen:
status: New → Confirmed
tags: added: checkin
tags: added: webstaffblocker
Jeff Davis (jdavis-sitka) wrote :

Since this is tagged with "webstaffblocker" I've set the importance to Medium, not sure if it should be set to High.

Changed in evergreen:
importance: Undecided → Medium
Bill Erickson (berick) on 2018-06-19
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
status: Confirmed → In Progress
Bill Erickson (berick) wrote :
Changed in evergreen:
milestone: none → 3.1.3
status: In Progress → Confirmed
assignee: Bill Erickson (berick) → nobody
tags: added: pullrequest
Changed in evergreen:
milestone: 3.1.3 → 3.1.4
tji@sitka.bclibraries.ca (tji) wrote :

Tested on Sitka's server. Works as expected.

Jeff Davis (jdavis-sitka) wrote :
tags: added: signedoff
Chris Sharp (chrissharp123) wrote :

Pushed to master, rel_3_0, and rel_3_1.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers