live_t/24-offline-all-assets.t failure

Bug #1751318 reported by Jason Etheridge on 2018-02-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

related to bug 1739803

live_t/24-offline-all-assets.t:
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests

# Failed test 'No missing assets required by the offline interface'
# at live_t/24-offline-all-assets.t line 7.
# got: '1'
# expected: '0'
# Looks like you failed 1 test of 1.

Bill Erickson (berick) wrote :

Confirmed this is happening on a new Ubuntu 16.04 build as well.

Changed in evergreen:
status: New → Confirmed
Bill Erickson (berick) wrote :

--2018-02-23 15:13:40-- https://localhost/js/ui/default/staff/build/js/angular-tablesort.js
Reusing existing connection to localhost:443.
HTTP request sent, awaiting response... 404 Not Found
2018-02-23 15:13:40 ERROR 404: Not Found.

Looks like we have a superfluous reference to angular-tablesort.js in offline-interface.tt2. The import should no longer be needed since it was added to vendor.bundle.js. Patch en route to remove it.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Fix pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1751318-webpack-tablesort-livetest

To test:

1. build, install, run
2. cd Open-ILS/src/perlmods/live_t && prove 24-offline-all-assets.t
3. Confirm test passes.
4. Navigate to offline UI in web staff and confirm page functions normally.

Changed in evergreen:
milestone: none → 3.1-beta
tags: added: pullrequest webstaffclient
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
importance: Undecided → Medium
Jason Stephenson (jstephenson) wrote :

Since I apparently don't know what "functions normally" means for the offline interface, I can't sign off on this fix.

Yes, it fixes the test, but the offline UI doesn't work if Apache is stopped on the server. The only way that I was able to get it to work was if I actually entered offline mode before the connection to the server was lost. This was true on repeated uses of the web staff client, and I made sure to visit the offline interface at least once before trying it with Apache stopped.

So, I don't know if the above behavior is normal, a new bug caused by something else, or a result of this patch, though I'm leaning toward #2.

This happened with OpenSRF and Evergreen master with this branch applied. PostgreSQL version is 9.4. Host O/S is Ubuntu 14.04. Client O/S is Ubuntu 17.10. Browser is Chromium Version 64.0.3282.140 (Official Build) Built on Ubuntu , running on Ubuntu 17.10 (64-bit).

I also tried enabling Chromium's own offline caching and that didn't seem to help, either.

Changed in evergreen:
milestone: 3.1-beta → 3.1-rc
Jason Stephenson (jstephenson) wrote :

So, I got lost in what was happening with Comment #4 and forgot about this bug after a few days and opened a new one.

Along the way, I figured out that offline mode just doesn't work in Chromium (Chrome's open source sibling).

Anyway, I tested this patch today. It fixed the test failures and offline still works for me in Firefox, so I've pushed it for testing happiness.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers