Webstaff: Grids on Bills and Patron Messages Screens do not show properly

Bug #1749593 reported by Jason Stephenson on 2018-02-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.0
High
Unassigned

Bug Description

Evergreen: Master (b35f0c0)
OpenSRF: Master

I was using the concerto patron, Leon Anderson, to test some things today and noticed that the Bills and Messages grids in the web staff client do not display properly. (See attached screen shot for the Bills interface.) The JS console has the following error message:

angular.js:14199 TypeError: Cannot set property 'grid' of undefined
    at controller.grid.init (grid.js:183)
    at controller (grid.js:1227)
    at Object.invoke (angular.js:4771)
    at R.instance (angular.js:10592)
    at n (angular.js:9469)
    at angular.js:9886
    at angular.js:16696
    at m.$eval (angular.js:17994)
    at m.$digest (angular.js:17808)
    at m.$apply (angular.js:18102)
(anonymous) @ angular.js:14199
(anonymous) @ angular.js:10707
(anonymous) @ angular.js:16704
$eval @ angular.js:17994
$digest @ angular.js:17808
$apply @ angular.js:18102
(anonymous) @ angular.js:13946
dispatch @ jquery.min.js:3
r.handle @ jquery.min.js:3

The error message is repeated 2x on the message interface as there are two grids there that have this issue.

Jason Stephenson (jstephenson) wrote :

Here's a branch based on a comment from Bill Erickson in IRC (http://irc.evergreen-ils.org/evergreen/2018-02-14#i_345818):

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1749593-fix-set-grid-dataprovider-grid

It works for me, so I'm adding the pullrequest tag. Looks like it probably needs to be backported to rel_3_0 also, but I leave that as an exercise for the tester.

tags: added: pullrequest
no longer affects: evergreen/3.1
Changed in evergreen:
milestone: none → 3.1-beta
Jason Stephenson (jstephenson) wrote :

I force pushed a fixed commit message. I was really tired when I got home from work.

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Jason Stephenson (jstephenson) wrote :

I also saw this behavior on patrons who have fines while working on bug 1749992. It seems to happen the first time I look at a patron's bills, but I haven't really made that thorough of an investigation. The patch does resolve it for me every time, though.

Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
Kathy Lussier (klussier) wrote :

Thanks Jason and Bill! It works for me.

Merged to master and backported to release 3.0.

Changed in evergreen:
status: New → Fix Committed
importance: Undecided → High
tags: added: regression
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers