Bill Payment receipts printing regardless of errors

Bug #1746830 reported by Terran McCanna
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
High
Unassigned

Bug Description

In 3.0.2, Chrome:

We are getting multiple reports of errors with bill payment receipts. The only one I have been able to reproduce consistently is https://bugs.launchpad.net/evergreen/+bug/1743262 but I am starting this ticket as a general ticket to add information to as we move along in hopes that other libraries may have input as well.

One problem we are seeing is staff entering a payment and having a receipt print out showing that they paid, but the account does not indicate that they have paid. Sometimes staff report that there is a pop-up error that they click through before the receipt prints. (I suspect this may be the same problem as 1743262 where an error occurs that should prevent the receipt from printing, but does not prevent it.)

Another problem we have had a few reports of is the receipt printing with no popup errors but missing information on the receipt. The payment also doesn't get applied. When staff tries reapplying the payment a second time, it will work and print properly. (Scan attached with example of this - the receipt on the left printed first with missing data and the patron account did not show that the payment was applied. The receipt on the right printed correctly the second time.)

I'm taking the liberty of marking this High since it involves money.

Revision history for this message
Terran McCanna (tmccanna) wrote :
Revision history for this message
Bill Erickson (berick) wrote :

Fixes pushed to bug #1743262 will likely impact this, possibly resolve it.

Revision history for this message
Terran McCanna (tmccanna) wrote :

This was fixed as a result of the fix to bug #1743262

Changed in evergreen:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers