wishlist: enhance egGrid to allow CSS styling

Bug #1746824 reported by Andrea Neiman
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Web staff client 3.0+

This is a wishlist item to address capitalization concerns alluded to here: https://bugs.launchpad.net/evergreen/+bug/1528924/comments/3.

To wit:
- allow eg-grid-field to be passed CSS class names
- teach egGrid to tack on an automatically-generated CSS class name
based on the path; e.g.,eg-grid-field-call_number-record-simple_record-author or the like to
allow per-field styling
- teach egGrid to accept an ID for the overall grid, which will also
help with styling.

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Andrea Neiman (aneiman) wrote :

Equinox has been contracted by PaILS to address this bug.

Revision history for this message
Cesar V (cesardv) wrote :

A branch for this is here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1746824-egGrid_CSS_cell_styling

Note first commit is the egGrid modifications, and the second (last) commit is just a CSS rule, which addresses the capitalization of titles in the Patron Itemsout grids and similar grids.

Andrea Neiman (aneiman)
tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.0.4
Revision history for this message
Kathy Lussier (klussier) wrote :

Adding a note that when I asked about this in IRC, Andrea noted that her preference is to backport this patch if it merges cleanly.

I'm not going to weigh in on whether it should be backported or not, but I wanted to make a note that the CSS in the last commit is probably unnecessary in 3.1 since we are adding Display Fields to these interfaces, which will result in proper capitalization. I would recommend removing that commit for 3.1.

Revision history for this message
Andrea Neiman (aneiman) wrote :

Let me clarify further with my brain fully engaged -- this is intended to bring capitalization into the 3.0 series, as that was PaILS's request. So that is why I set the target for 3.0.4.

Revision history for this message
Mike Rylander (mrylander) wrote :

However, I will say that having the ability to style specific cells would be great in 3.1+, so at least the first commit should go into master, IMO. I'll leave that to Dan Wells to consider, though, as we're past targeting time.

Revision history for this message
Kathy Lussier (klussier) wrote :

Agreed that the first commit will be useful beyond 3.0.

Changed in evergreen:
milestone: 3.0.4 → 3.0.5
Changed in evergreen:
milestone: 3.0.5 → 3.0.6
Changed in evergreen:
milestone: 3.0.6 → 3.0.7
Changed in evergreen:
milestone: 3.0.7 → 3.0.8
Revision history for this message
Mike Rylander (mrylander) wrote :

I've added a signoff to Cesar's branch, and a followup commit that allows CSV downloaded from a grid to benefit from title casing. Coordinates:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/miker/lp1746824-egGrid_CSS_cell_styling-signoff

tags: added: signedoff
Changed in evergreen:
milestone: 3.0.8 → 3.2-beta
Revision history for this message
Bill Erickson (berick) wrote :

Reviewing now... Just to clarify, the titlecase additions are basically a stop-gap for broader Display Field adoption?

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Mike Rylander (mrylander) wrote :

Bill, that's correct.

Revision history for this message
Bill Erickson (berick) wrote :

So +1 to the grid cell CSS options. However, I suspect some changes may be needed once bug #1635386 is merged.

I'm less gung-ho on the titlecase changes, especially the English-centric titlecase filter. I worry that might have unintended side effects for non-English data.

Thoughts? I'll hold off in merging pending feedback.

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Revision history for this message
Galen Charlton (gmc) wrote :

The branch user/gmcharlt/lp1746824_grid_css_styling has a rebased version of the main patch that also includes more usage information in the commit message. The two patches for title-casing are no longer necessary in master due to the display fields improvements; while they may not be a bad idea for 3.0, they're not a priority for Equinox.

Revision history for this message
Kathy Lussier (klussier) wrote :

I like it! Merged to master for inclusion in 3.2. Thank you Cesar, Mike and Galen!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers