The <img> tag for the Web staff client's patron photo does not include an alt attribute

Bug #1744585 reported by Jane Sandberg on 2018-01-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Medium
Unassigned

Bug Description

This is true of master as of 21 January, 2018. Setting the alt text to the localized version of "Patron photograph" seems like a simple way to fix this. Setting the alt text to the localized version of "Photograph of [Patron Name]" seems even better, although not quite as easy.

Sam Link (slink-g) wrote :

I'm thinking that having a null alt attribute might be a better choice since the picture itself isn't providing account information. G94 of WCAG 2.0 indicates that alternative text should provide the same information as the non-text content - as the alt text wouldn't be able to provide the visual identification aspect of the patron photo, and the image doesn't act as navigation or contain any other account data, it's not contributing the same information, it's simply stating the presence of the image.

A null alt attribute would be easy to add, and would conform to H67 of WCAG 2.0 and non-disruptively remove the image from the flow of a screen reader or other AT.

Jane Sandberg (sandbej) wrote :

Very good point, Sam. I'd be good with a null alt attribute.

Sam Link (slink-g) on 2018-01-24
Changed in evergreen:
status: New → Confirmed
Sam Link (slink-g) wrote :

I've pushed a fix to the branch at:

user/slink/lp1744585-patron-photo-img-tag-alt-attribute

Just added the alt="" into the image tag on the t_summary.tt2 file.

Jane Sandberg (sandbej) on 2018-01-25
tags: added: pullrequest
Galen Charlton (gmc) on 2018-02-06
Changed in evergreen:
milestone: none → 3.1-beta
importance: Undecided → Medium
Changed in evergreen:
milestone: 3.1-beta → 3.1-rc
Cesar V (cesardv) wrote :

Hi Sam, thanks for your patch!

I tested this and your markup change is definitely a good WCAG improvement.

In your Git branch, however, there were a few stray deletions to unrelated files that got committed.

Thus, I went just ahead and cherry-picked+amended your changes related to this bug and pushed them to clean/new signed-off branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/slink_lp1744585-patron-photo-img-tag-alt-attribute-SIGNOFF

Just FYI... the stray deletions that I stripped from the branch were to the unrelated files below:

[deleted] Open-ILS/src/edi_translator/data/test_output/ruby_json2edi.tmp (first commit)
[deleted] Open-ILS/src/edi_translator/data/test_output/perl_json2edi.tmp (first commit)
[deleted] docs/RELEASE_NOTES_NEXT/Circulation/Patron_Email_Addresses_Now_Clickable.adoc (second commit)

Sam Link (slink-g) wrote :

Thanks! I'm not sure how those got into the commit, so thanks for catching them and fixing it.

Cesar V (cesardv) on 2018-03-16
tags: added: signedoff
Changed in evergreen:
milestone: 3.1-rc → 3.1.1
Changed in evergreen:
milestone: 3.1.1 → 3.1.2
Galen Charlton (gmc) wrote :

Pushed to master, rel_3_1, and rel_3_0. Thanks, Sam and Cesar!

Note that because this is just a bugfix and doesn't require special instructions, I did not push the release notes entry.

Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
assignee: Galen Charlton (gmc) → nobody
Galen Charlton (gmc) on 2018-04-30
Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers