Web client: merging records holdings displayed by default

Bug #1739293 reported by Elaine Hardy on 2017-12-19
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

In the web client, records to be merged are displayed vertically with their holdings displayed, if merging several records with large numbers of holdings attached, user must do a lot of scrolling to identify the target record in the list.

Kate Coleman (katecoleman) wrote :

+1

When a lead record is chosen, they do go into a more horizontal pattern, but still not as nicely as they did in XUL. The merge functionality is so great in the XUL client, I'd love to see it replicated for webclient.

Changed in evergreen:
status: New → Confirmed
Anna Goben (agoben) wrote :

Since most current Evergreen users do read horizontally, I would much prefer the vertical scroll with holdings immediately visible if the selected lead record was anchored to the left side so it could then be compared side by side with each non-lead record. (See attached mockup)

Janet Schrader (jschrader) wrote :

+1
I see no reason for the attached holdings to display in the web client. In xul you could select view holdings and the holdings maintenance view replaced the bib record display. I'd like to see the same behavior in the web client where you could choose to hide/display holdings. It wouldn't necessarily have to replace the bib record, could still be below.

Today I merged three serial records. One had over 1700 holdings, I added that one to the bucket last, but still another record had 100+ holdings. A lot of scrolling if one is trying to compare records.

When I have multiple records to merge I appreciate the ability to select two to merge (not like xul where its all of nothing), merge those, then select the lead record and another one. That way I am comparing only two records side-by-side and not two tiled vertically and one or more below.

Meg Stroup (mstroup) wrote :

+1 for SCLENDS

I've often gotten to the point in the web client where I have selected my lead record vertically, only to change my mind when I was able to "read" the records in the traditional horizontal display.

Bill Erickson (berick) wrote :

+1 for KCLS.

Bill Erickson (berick) wrote :

It would also be nice to have the merge/cancel buttons duplicated along the top of the dialog.

Bill Erickson (berick) wrote :

Adding code to:

1. Display records horizontally
2. Add a holdings view toggle button, with holdings not displayed by default.
3. Duplicate the merge/cancel buttons along the top of the dialog.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :
Changed in evergreen:
milestone: none → 3.2.4
assignee: Bill Erickson (berick) → nobody
tags: added: cataloging pullrequest webstaffclient
Janet Schrader (jschrader) wrote :

It would also be nice if bug 1746611 could be included in this development, deleted records not highlighted, i.e. red bar, on merge record screen.

Changed in evergreen:
milestone: 3.2.4 → 3.2.5
Elaine Hardy (ehardy) wrote :

Testing in sandbox.

The records are horizontal rather than vertical, however they take up so much space that I have to scroll down to the scroll horizontal scroll so far I can no longer see the record. Horizontally, they take up so much space and long fields don't wrap, that I have to scroll horizontally to find the next record.

This means I am scrolling blindly horizontally since I have to scroll beyond the bottom of each record and thus have to keep scrolling up to find the beginning of the next record.

Toggling holdings view works nicely with the same caveat of the size

Merge button is both top and bottom.

Bill Erickson (berick) wrote :

Thanks, Elaine. Sounds like we need a maximum width on the MARC records so they don't stretch out so far.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

I have pushed another commit. I tried to mimic the behavior of the XUL client more closely. Now, all records fit horizontally on the screen, regardless of the number of merged records. This is accomplished by allowing the text within the records to wrap on overflow (like the XUL client). There is a single vertical scroll bar to scroll down to see the bottoms of longer records.

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Bill Erickson (berick) wrote :

Oops, forgot to make the same change to the lead record once it's selected.. Patch en route.

Bill Erickson (berick) wrote :

Fix pushed. The lead record now honors the formatting. Also, like the XUL client, when using the inline editor, the text no longer wraps, but overflows to the right with a horizontal scroll bar.

Elaine Hardy (ehardy) wrote :

Tested on sandbox.

I have tested this code and consent to signing off on it with my name, Elaine Hardy and my email address, <email address hidden>"

tags: added: signedoff
Bill Erickson (berick) on 2019-03-13
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Thanks, Elaine. Did another round of testing and have now merged to 3.2 and above.

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers