Circulation Library in Item Status

Bug #1738249 reported by Scott Thomas on 2017-12-14
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
3.0
Low
Unassigned

Bug Description

Web Client

In Item Status list view, the column picker option "Circulation Library" displays the full library name. Displaying the OU shortname here is preferable, and consistent with what was done in XUL as well as what is used in the Item Status detail view.

Kathy Lussier (klussier) wrote :

Adding a couple of other issues I found with the web client column pickers. I'm adding them to this bug because it's easier to fix them all at once than in separate branches.

* The Circulation Library column in item status is displaying the value for the Checkout/Renewal Library, not the copy's circulation library.

* The action.circulation columns are not populating at all.

A working branch is forthcoming that will display the shortname for asset.copy circulation library for the Circulation Library field, populate the action.circulation columns, and use the shortname for the checkout/renewal library.

Changed in evergreen:
status: New → Confirmed
assignee: nobody → Kathy Lussier (klussier)
importance: Undecided → Low
Kathy Lussier (klussier) wrote :

My comment that action.circulation columns are not populating was a bit of an overstatement as it appears there were just two that were not populating.

The working branch at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1738249-item-status-column-fixes does the following:

  * The Circulation Library field now displays the asset.copy circ library
    instead of the checkout library.
  * The Circulation Library and Checkout / Renewal Library now show the
    shortname instead of the full name.
  * A typo fix that allows Remaining Renewals to populate.

There were two related issues I was unable to resolve:
   * The owning lib is displaying the ID of the owning org unit. I tried adding .name and .shortname, but neither works in this interface.
   * The checkout / renewal workstation does not populate. We have a field for checkout workstation that does populate. However, this field doesn't display the workstations for renewals, which is typically included in the checkout / renewal combo.

We could merge the above branch and file separate bugs on these other two issues, but it would be nice to fix them all if we can.

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
Elaine Hardy (ehardy) wrote :

Isn't the label in item status list view for this is incorrect -- the Circulating library is the checkout library. Circulation library is the library, usually the owning library, where the item resides. See item attribute editor in the XUL client.

Kathy Lussier (klussier) wrote :

Yes, that's one of the corrections I made in my branch. With the branch, the Circulation Library field will now display the asset.copy Circulation Library.

Kathy Lussier (klussier) wrote :

I'm going to add a pullrequest tag for this branch now to see if we can get a fix merged for the issues I identified above.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.0.3
Cesar V (cesardv) wrote :

Hi Kathy, thanks for creating a branch for this. I had a branch our there for the duplicate bug 1743661, but since we basically did the same thing, I'll create a signoff branch for yours and I'll try and see if I can get the other issues you mentioned corrected.

Elaine Hardy (ehardy) wrote :

Kathy -- thanks for the clarification -- I read that sentence but wasn't sure if it meant the label was changed!

Kathy Lussier (klussier) wrote :

Well, the label doesn't change. It still is Circulation Library. The data displaying for this field changes. The circulating library is already displaying under the Checkout/Renewal Library.

Elaine Hardy (ehardy) wrote :

I think I need more coffee......

Cesar V (cesardv) on 2018-01-17
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Changed in evergreen:
milestone: 3.0.3 → 3.0.4
Cesar V (cesardv) wrote :

Here's a signoff branch for Kathy's commit (thanks!), with another commit that addresses the owning_lib display issue (not being fleshed out).

There is definitely an issue with the checkout and check-in workstations not showing up, that I was not able to figure out. It seems that even though both fields are set to be fleshed out (in the Pcrud call) that doesn't actually happen. It might be a permission issue or a pcrud bug. Not sure, so it might be worth filing that as a separate bug.

Terran McCanna (tmccanna) wrote :

I've tested Kathy's and Cesar's branches against real data and the combined branches worked for me.

I have tested this code and consent to signing off on it with my name, Terran McCanna and my email address, <email address hidden>.

tags: added: signedoff
Cesar V (cesardv) on 2018-01-26
Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Galen Charlton (gmc) wrote :

While testing this, I came up with a couple follow-up patches. I'm reasonably confident with the current state of the branch, but ask Kathy (or whomever) to review the result before merge.

Branch is user/gmcharlt/lp1738249_signoff

Cesar V (cesardv) wrote :

I've rebased the above signoff branch and fixed a glaring thinko in one of my earlier commits. Should not affect any of the other changes:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1738249_signoff_rebase

Changed in evergreen:
milestone: 3.0.4 → 3.0.5
Changed in evergreen:
milestone: 3.0.5 → 3.0.6
Changed in evergreen:
milestone: 3.0.6 → 3.0.7
Jason Stephenson (jstephenson) wrote :

We're testing this on 3.0.6 at CW MARS.

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Changed in evergreen:
milestone: 3.0.7 → 3.0.8
Changed in evergreen:
milestone: 3.0.8 → 3.next
Jason Stephenson (jstephenson) wrote :

Works for me! Pushed to master, rel_3_1, and rel_3_0.

Thanks everyone who worked on and looked at this branch.

Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
status: Confirmed → Fix Committed
no longer affects: evergreen/3.1
Changed in evergreen:
milestone: 3.next → 3.1.2
status: Fix Committed → Fix Released
Changed in evergreen:
status: Fix Released → Confirmed
status: Confirmed → In Progress
milestone: 3.1.2 → 3.1.4
Jason Stephenson (jstephenson) wrote :

I have reopened this bug because the actual issue was not fixed. I'm not sure exactly how, but when I added the branch to master, etc., the change that actually addresses the change to the Circulation Library in Item Status was dropped from the first commit. It's entirely my fault, and I will not speculate on the how, there are a few possibilities that I can think of.

Since the affected file appears to be different in rel_3_0 versus master and rel_3_1 and to prevent any possible issues with conflict resolution, I have made 3 branches, one for each active mainline branch:

working/user/dyrcona/lp1738249-circulation-library-master
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1738249-circulation-library-master

working/user/dyrcona/lp1738249-circulation-library-rel_3_1
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1738249-circulation-library-rel_3_1

working/user/dyrcona/lp1738249-circulation-library-rel_3_0
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1738249-circulation-library-rel_3_0

Changed in evergreen:
status: In Progress → Confirmed
Scott Thomas (scott-thomas-9) wrote :

At 3.0.9 it does not appear to be fixed.

Scott

Kathy Lussier (klussier) wrote :

Thanks for catching the omission, Jason, and for creating the branch to get it back in! Merged to master, release 3.1 and 3.0.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers