Web Client: Patron name fields missing from checkout printer template

Bug #1737540 reported by Robert J Jackson on 2017-12-11
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Medium
Unassigned

Bug Description

Inserting the following in the checkout template on the webclient results in the patron first and last name being displayed in the preview pane:

<div>
    {{patron.first_given_name}}
    {{patron.second_given_name}}
</div>

However, when printing the actual receipt nothing is printed on either field.

Kathy Lussier (klussier) wrote :

Confirming, but I'm also adding a clarification that {{patron.second_given_name}} should show the patron's middle name and that {{patron.family_name}} should show the patron's last name.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
tags: added: webstaffclient
Jason Boyer (jboyer) wrote :

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1737540-patron-info-receipts

adds the following fields to Checkout, Items Out, and Bill Payment:

suffix,
first_given_name,
second_given_name,
suffix,
card.barcode (Not an actual actor.card),
money_summary.balance_owed, (Not on Bill Payment)
money_summary.total_owed, (See above)
money_summary.total_billed, (See above)
expire_date,
alias,
has_email (boolean),
has_phone (boolean)

There is also some help text added to the print templates.

This has had some light testing so far on a dev server but additional testing is appreciated.

tags: added: pullrequest
Jason Boyer (jboyer) on 2018-02-08
Changed in evergreen:
milestone: none → 3.0.4
Jason Stephenson (jstephenson) wrote :

We have some interest in this at CW MARS, so we'll test this with some templates of our own.

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Jason Stephenson (jstephenson) wrote :

We've been looking at this at CW MARS and just wanted to point out that the comments in the code are correct about the fields from money summary that are available, and that Jason's list in comment #2 is wrong.

There is not total_billed field in money user summary. The 3 fields available should be balance_owed, total_owed, and total_paid as mentioned in the code comments.

With that in mind, this looks good. I'm waiting on the OK from other staff here to sign off on this branch.

I wonder if this should have release notes/documentation to list the new files that are available. Also, is this really a bug in 3.0? I have no objection to it going into 3.0 even if it isn't. I assume it's classed as a bug because this is a feature from XUL that is missing in the web staff client.

Thanks for your effort on this Jason!

Jason Boyer (jboyer) wrote :

Huh, not sure why I didn't just copy/paste that list out of the template comments.

As for the bug-ness of it, in addition to being a missing XUL client feature, it was something that worked in the template preview of 3.0. This lead staff to believe that they should have already been able to include patron information and that it wasn't working. That's also why I didn't think to include release notes but if there's interest I can throw some in (with the correct field names).

Jason Stephenson (jstephenson) wrote :

Jason, your explanation of bugness works for me. I didn't really make the connection with the preview pane. (I mainly started from your comment #2.)

The code works for us at CW MARS, so I'm pushing to master and rel_3_0.

Thanks again for doing this!

Changed in evergreen:
milestone: 3.0.4 → 3.1-beta
assignee: Jason Stephenson (jstephenson) → nobody
status: Confirmed → Fix Committed
tji@sitka.bclibraries.ca (tji) wrote :

I wonder whether patron's primary ID can be added.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers