Acq: Funding Source codes should be unique to owners, not the entire system

Bug #1737016 reported by Jason Boyer on 2017-12-07
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Funds have a unique constraints on (org,code,year) and (org,name,year) which is very convenient because one org may not be able to see another's funds to know what codes they may use. Funding Sources, though, require a completely unique code across the entire Evergreen system. Since you can't see others' sources this can be a frustrating endeavor that usually ends up with libraries throwing up their hands and adding their system or branch shortname to all of their funding source names as well. This makes them unnecessarily long for no reason, given that they're not actual keys of any kind.

Kathy Lussier (klussier) on 2017-12-07
Changed in evergreen:
status: New → Confirmed
Jason Boyer (jboyer) wrote :
tags: added: pullrequest
Jason Boyer (jboyer) wrote :

Jeff Davis pointed out a step I missed in that upgrade script. If you've looked at that branch since 2017-12-07 16:30 EST, reload it; a fix was squashed and force-pushed.

Galen Charlton (gmc) on 2018-01-11
Changed in evergreen:
importance: Undecided → Wishlist
milestone: none → 3.next
Dan Wells (dbw2) on 2018-02-13
Changed in evergreen:
milestone: 3.next → 3.1-beta
Remington Steed (rjs7) wrote :
tags: added: signedoff
Dan Wells (dbw2) on 2018-02-27
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Dan Wells (dbw2) wrote :

Looks good, pushed to master. Thanks, Jason and Remington!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Dan Wells (dbw2) → nobody
Dan Wells (dbw2) wrote :

P.S. This could be seen as a bugfix, but being a schema change, I hesitate. It is very simple, though, so I will target for further consideration.

Changed in evergreen:
status: Fix Committed → Fix Released
Kathy Lussier (klussier) wrote :

I consulted with Galen about this bug in IRC, and we're going to leave this one as a new 3.1 feature. Thanks Jason, Remington and Dan!

no longer affects: evergreen/2.12
no longer affects: evergreen/3.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers