Default SMS Carrier in Web Staff Client does not reflect reality

Bug #1736243 reported by Bob Wicksall on 2017-12-04
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.1
Medium
Unassigned

Bug Description

Evergreen 3.0.2
Web Staff Client

While editing a patron in Web staff client, "Default SMS Carrier" just displays "Select a Carrier" regardless of actual setting.

Patron's "Default SMS Carrier" is correctly displayed in OPAC and old staff client.

Bob Wicksall (bwicksall) on 2017-12-04
tags: added: webstaffclient
Terran McCanna (tmccanna) wrote :

We're seeing this problem as well.

Patrons that already had a carrier set prior to our upgrade are now showing "Select a Carrier" when opening them in the web client edit screen. Logging into the OPAC shows the carrier as it should.

When I edit and re-save the carrier in the web client, it then shows up as it should after that for that patron.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Terran McCanna (tmccanna) wrote :

It looks like the Carrier id was stored as a string in earlier versions and now it's stored as a number.

Blake GH (bmagic) wrote :

Bob and Terran,

I found this issue also but I added it to bug 1361258.

Chauncey Montgomery (montgoc1) wrote :

We have had several patrons that get an internal server error when trying to place a hold. While I'm not sure if it is related specifically to this carrier issue, the issue does resolve when we select a carrier. We're using 3.0.3.

Jason Boyer (jboyer) wrote :

There is a directive that we can use to make the web client treat these values as strings just like the XUL client used to. In the future when there's no need to run side-by-side with the XUL client this can be revisited (along with an upgrade script that mass-converts them) but for now it needs to honor the old ways.

Branch on its way.

Jason Boyer (jboyer) wrote :

This branch takes care of the SMS Carrier setting in the patron editor:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1736243_sms_carrier working/user/jboyer/lp1736243_sms_carrier

tags: added: pullrequest
Chris Sharp (chrissharp123) wrote :

Works for us! Fix pushed to master, rel_3_0 and rel_3_1.

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: none → 3.0.10
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers