Patron Search button on Place Hold screen does not work

Bug #1736200 reported by Bob Wicksall on 2017-12-04
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Evergreen 3.0.1 and 3.0.2
Web Staff Client

The new "Patron Search" button on the Place Hold screen does not work in our environment.

1) Click "Patron Search". The popup displays.
2) Try a search. No results are returned and the following displays in the console:

  angular.js:14199 TypeError: Cannot read property 'map' of undefined
    at patron_search.js:261
    at Object.q [as forEach] (angular.js:325)
    at Object.service.localFlesh (patron_search.js:257)
    at patron_search.js:704
    at angular.js:16785
    at m.$eval (angular.js:17994)
    at m.$digest (angular.js:17808)
    at angular.js:18033
    at f (angular.js:6045)
    at angular.js:6324

Bob Wicksall (bwicksall) on 2017-12-04
tags: added: webstaffclient
Revision history for this message
Deborah Luchenbill (deborah) wrote :

We can confirm this. Is it related to bug 1724052?

Revision history for this message
Terran McCanna (tmccanna) wrote :

Are you getting the same error regardless of what type of search you are doing? As I said in bug 1724052, we're getting some results, but not *all* results and we're not seeing any obvious pattern. We ended up hiding the button in our implementation until it is working better.

Kathy Lussier (klussier) on 2018-01-02
Changed in evergreen:
status: New → Confirmed
Revision history for this message
Bob Wicksall (bwicksall) wrote :

Sorry I didn't respond earlier. My notifications were landing in my spam folder... I also didn't see bug 1724052.

My test was with real data upgraded from 2.10 to 3.0.2. No matter how I scope the search I get 0 results.

The error above seems to happen in every case multiple times. It corresponds to the number of patron results that should have returned. If an org unit has 23 Smiths there will be 23 errors in the console.

Revision history for this message
Kathy Lussier (klussier) wrote :

Adding a note that when I replicate the problem in bug 1724052, I see the same error in the Console that Bob noted above. Given that we are seeing the same error messages, I'm going to mark this one as a duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers