Cannot Delete Existing Copy Notes

Bug #1735816 reported by Robert J Jackson on 2017-12-01
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Undecided
Unassigned
3.1
Undecided
Unassigned

Bug Description

webclient 3.0

Cannot delete a copy note using the webclient. Permissions verified - same account can perform activity fro m legacy staff client. No messages returned indicating any issues.

Including attachment of steps followed.

Robert J Jackson (rjackson) wrote :
tags: added: webstaffclient
Kathy Lussier (klussier) wrote :

Robert,
In which point release of 3.0 did you see this behavior? There was a fix in today's 3.02 release for this issue. Are you still seeing it there?

See bug 1724223.

Robert J Jackson (rjackson) wrote :

Kathy,

Jason is ooo today and he handles all of the release/updates. I would say go ahead and mark this one as a duplicate though! Sorry - did some searching first and didn't find his bug report :(

Kathy Lussier (klussier) wrote :

OK, I just checked this on a system I built from master today, and I see the issue. However, in my case, but it's a little different.

After opening the copy with the copy note in the copy editor, I click the Copy Note button, select the delete box, and then click the X.

I click Save and Exit. However, in my case, I remain on the copy editor page. The copy information is removed from the working copies tab, and values for the other fields are wiped out.

Also, I want to add a note that I find the UI here a little confusing. I wasn't quite sure what to do after selecting the delete checkbox. I went with OK, but as was noted in Robert's documentation, this adds a blank note field.

Possibly related to bug 1721050.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Kathy Lussier (klussier) wrote :

Actually, it looks like the copy tag issue has been fixed, probably by the same code that was supposed to fix the copy note issue.

Another note on the UI for the copy notes, if we made UI more like the copy tag UI, I think removing the note would be more intuitive. In that case, there is a button that you click to remove, and then you click OK to leave the modal.

Kathy Lussier (klussier) wrote :

This is what I see in the browser console after clicking Save & Exit:

error calling method open-ils.cat.asset.volume.fleshed.batch.update.override : 500 : *** Call to [open-ils.cat.asset.volume.fleshed.batch.update.override] failed for session [0.64271225387241991512162029722], thread trace [0]:
Can't locate object method "properties" via package "1" (perhaps you forgot to load "1"?) at /usr/local/share/perl/5.18.2/OpenILS/Utils/CStoreEditor.pm line 696.

Mary Llewellyn (mllewell) wrote :

Testing in 3.1 and I still can't delete a copy note or save and exit from the Volume/Copy editor when I try.

Console message:

error calling method open-ils.cat.asset.volume.fleshed.batch.update.override : 500 : *** Call to [open-ils.cat.asset.volume.fleshed.batch.update.override] failed for session [0.79036701091920641527701616836], thread trace [0]:
Can't locate object method "properties" via package "2814886" (perhaps you forgot to load "2814886"?) at /usr/local/share/perl/5.18.2/OpenILS/Utils/CStoreEditor.pm line 696.

Jason Boyer (jboyer) wrote :

There were a couple of issues holding this up, here's a branch that clears the way:
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1735816_del_copy_notes_web working/user/jboyer/lp1735816_del_copy_notes_web

Works well for me, hopefully we can squeeze this in before the releases next week!

tags: added: pullrequest
Remington Steed (rjs7) wrote :

I tested Jason's branch and can confirm that it fixes the delete error, and the annoying duplication of empty note forms.

Sign off branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/rsteed/lp1735816_del_copy_notes_web

tags: added: signedoff
Remington Steed (rjs7) wrote :

I created a new bug for a related issue about the "Public" checkbox not sticking: Bug #1778571

Remington Steed (rjs7) wrote :

And I agree with Kathy's sentiment that the Copy Notes UI would benefit from a redesign.

Changed in evergreen:
milestone: none → 3.1.4
Changed in evergreen:
milestone: 3.1.4 → 3.1.5
Mary Llewellyn (mllewell) wrote :

I agree with Kathy and Remington about redesigning the Copy Notes UI. The current form is not intuitive at all.

Jason Boyer (jboyer) wrote :

I've force-pushed a fix for the UI to make copy notes behave more like copy tags: changed the checkbox to a button, changed Deleted? to the action word Remove and hide it completely when removed. (It isn't actually deleted until the copy is saved, so nothing is lost at that point.)

Jason Boyer (jboyer) on 2018-08-22
no longer affects: evergreen/3.2
Changed in evergreen:
milestone: 3.1.5 → 3.2-beta
Jason Boyer (jboyer) wrote :

I wish I had re-added the links to the branch to comment 13 so it's easier to scroll by and tell where the latest branch is for testing. In any case, here they are now, at the bottom of the comments:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1735816_del_copy_notes_web working/user/jboyer/lp1735816_del_copy_notes_web

updated 8/22 to address the UI.

And quick testing notes just in case:
Pre-patch, try to delete a copy note, get an ugly error in the console.

Apply patch

Click Remove on an existing copy note and then OK or Cancel to close the window. Do NOT save copy, note should still be attached.

Click Remove on an existing copy note and then OK or Cancel to close the window. SAVE the copy, this time the copy note is finally gone.

I did not take this opportunity to make it work 100% like the copy tags editor (add multiple notes at once, remove the Cancel button, etc.) though a UI realignment between tags, notes, and alerts would be worthwhile, it can probably wait until after it's possible to delete notes again.

Changed in evergreen:
milestone: 3.2-beta → 3.2-rc
tags: removed: signedoff
Janet Schrader (jschrader) wrote :

I tested this on 3.0.11 with all recent updates and this patch. Existing copy notes do not display when clicking on the copy notes button. Attached screenshot shows item with 2 public and 2 internal notes. The OPAC screenshot shows the 2 public notes; the copy notes in the item record show only the ability to add a new note and nothing for existing notes.

Chris Sharp (chrissharp123) wrote :

We can confirm Janet's observations in our testing the fix on a 3.0-ish PINES server, FYI.

Jason Boyer (jboyer) wrote :

All for want of a pair of parentheses... Fix force pushed to same location:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1735816_del_copy_notes_web working/user/jboyer/lp1735816_del_copy_notes_web

Amy Constantino (aconstantino) wrote :

I created a Public Copy Note and a non-Public Copy Note and was subsequently able to remove both.
I have tested this code and consent to signing off on it with my name, aconstantino, and my email address, <email address hidden>

tags: added: signedoff
Jason Stephenson (jstephenson) wrote :

Works for me, too! I added Amy's signoff and pushed to master, rel_3_1, and rel_3_0.

Thanks, everyone!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers