Web client: multiple copies will not display in item status (list)

Bug #1734775 reported by Elaine Hardy on 2017-11-27
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.1
Undecided
Unassigned
3.2
Undecided
Unassigned

Bug Description

When multiple copies are selected from the holdings view on a bib record and Show -- Item Status (list) is chosen, only one item appears in item status list view in the newly opened tab.

In XUL client, when multiple copies are selected and show item details is chosen, item status opens with one item in details view, however, if you change to list view, all copies chosen are in the list.

Revision history for this message
Elaine Hardy (ehardy) wrote :

Last sentence should be "if you change to list view, all copies chosen are in list"

Revision history for this message
Laura Sachjen (sachjenl) wrote :

Can confirm. Only the first item selected is showing in Item Status (list) in the web client.

Changed in evergreen:
status: New → Confirmed
Andrea Neiman (aneiman) on 2018-05-29
tags: added: cataloging webstaffclient
Changed in evergreen:
importance: Undecided → High
Michele Morgan (mmorgan) on 2018-12-06
description: updated
Revision history for this message
Jason Boyer (jboyer) wrote :

Promises, promises.

Because of the way various calls treat their parameters I couldn't precisely tell if you're supposed to be able to pass an array of copy ids to egItem.fetch or if it only expect singles. (It currently only fetches a single in any case.) Here's a branch that follows through on that assumption and makes multiple calls to egItem.fetch for every id in the list and now all items in the idlist are displayed.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1734775_multi_item_list / working/user/jboyer/lp1734775_multi_item_list

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.next
Jason Boyer (jboyer) on 2019-01-28
Changed in evergreen:
milestone: 3.next → 3.3-beta1
Revision history for this message
Josh Stompro (u-launchpad-stompro-org) wrote :

Evergreen 3.2.3 - I can confirm the reported problem.

After the fix is applied I can confirm that multiple items can be loaded in the item status list view from the holdings view.

Here is my signoff branch.
user/stompro/lp1734775_multi_item_list

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/stompro/lp1734775_multi_item_list

tags: added: signedoff
Changed in evergreen:
milestone: 3.3-beta1 → 3.3-rc
Revision history for this message
Elaine Hardy (ehardy) wrote :

Also confirmed this in sandbox test

Bill Erickson (berick) on 2019-03-08
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

Issue confirmed and fixed, merged to 3.1+. Thanks, all.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers