Web Client -- existence of record with duplicate TCN does not prevent import

Bug #1724321 reported by Elaine Hardy on 2017-10-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned

Bug Description

For web client 3.0

Preventing import (and sometimes overlay) of bib records with identical TCNs via Z39.50 gateway does not consistently occur. Multiple duplicate records can be imported. When an existing record in the database has the same TCN as the importing record, rather than import being prevented and warning of the collision, the record is imported and assigned an AUTOGENERATED TCN such as AUTOGENERATED_13433. This can occur multiple times for the same record.

Overlay of a record with a duplicate TCN is not always prevented either; but is some of the time.

PINES uses OCLC's WorldCat as a bib record source and imports records one at a time through the Z39.50 gateway. We use the OCLC TCN as our TCN (with the appropriate on, ocm, or ocn prefix) with the system supplied Database ID automatically entered in the 001. In the XUL client, this results in an added 035 with the OCLC tcn plus prefix (for example 035 $a(OCoLC)ocn927413447), retaining the 035 from the OCLC master record (for example 035 . $a(OCoLC)927413447 $z(OCoLC)944193595). In addition, the system assigns an internal Database ID, replacing the number in the 001. For example:

LDR 02231cam a2200565 i 4500
001 5773185
003 GaAaGPL
005 20171017134057.0
008 160827m20152016mdu 001 0 eng d
010 ‡a 2016429757
035 ‡a(OCoLC)ocn927413447
040 ‡aJPL ‡beng ‡erda ‡cDLC ‡dJPL ‡dBDX ‡dOCLCF ‡dUBY ‡dZGU ‡dOCLCO ‡dOCLCQ
035 ‡a(OCoLC)927413447 ‡z(OCoLC)944193595

In the web client, the OCLC TCN is not added as an additional 035 with the appropriate prefix (the Database ID is replacing the 001), For example:

LDR 01945cam a2200397Ia 4500
001 5881298
003 GaAaGPL
005 20171011125657.0
008 100322s1988 mouab b s001 0 eng d
040 ‡aMODOT ‡beng ‡cMODOT ‡dOCLCQ ‡dOCLCA ‡dOCLCF ‡dOCLCQ ‡dGSL
019 ‡a903506020
035 ‡a(OCoLC)566196926 ‡z(OCoLC)903506020
043 ‡an-us-mo
100 1 ‡aGeller, Jill Elaine Hardy, ‡d1960-

The record summary does have the correct TCN and Database ID listed.

This is a very serious problem for PINES libraries and will prevent us from migrating to the web client.

Changed in evergreen:
importance: Undecided → High
Chris Sharp (chrissharp123) wrote :

Adding a clarification of the workflow that leads to a failure of duplicate detection. First of all, you have to have the config.global_flag named 'cat.bib.use_id_for_tcn' set to 'false'. In my testing after that setting was changed on a stock master server, if you search z39.50 for a title, select one, then click "Import", it will fail to import because it sees the already-existing TCN, but you will not see any messages in the UI (see bug 1724885). However, if you click "Edit then Import", it will take you to the editing screen, and clicking "Import" there does not prevent you from importing the record with the duplicated TCN.

tags: added: webstaffblocker webstaffclient
Chris Sharp (chrissharp123) wrote :

Adding screenshot from xul client alert box when TCN collides.

Blake GH (bmagic) on 2017-11-10
tags: added: pullrequest
Chris Sharp (chrissharp123) wrote :
Changed in evergreen:
status: New → Confirmed
tags: added: signedoff
Changed in evergreen:
assignee: nobody → Jason Etheridge (phasefx)
Jason Etheridge (phasefx) wrote :

Looks good! Pushed to master. Chris, the signoff branch you shared was contaminated with your previous commit. I ended up just pushing Blake's commit after testing. Thanks guys!

Changed in evergreen:
milestone: none → 3.0.3
status: Confirmed → Fix Committed
assignee: Jason Etheridge (phasefx) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers