Web Client: Register Patron with same phone number alert not working

Bug #1723498 reported by Terran McCanna on 2017-10-13
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

In 3.0.0:

When creating a new patron with a phone number that already exists on another account, no alert appears.

(On demo.evergreencatalog.com, I'm not seeing any dup alerts at all.)

Kathy Lussier (klussier) wrote :

OK, I'm having trouble with this alert, but it's different from what Terran described.

I do get the duplicate patron alert, but it only appears as you tab out of the text-entry box where I typed the phone number box.

As I hover over the link for the duplicate alert, the URL for the link looks correct. Unlike my experience with the e-mail duplicate alert, I can see there are search terms added on to the URL.

When I click the link, no record is retrieved and the link disappears.

Although this is different from what Terran described, I'm marking this bug confirmed since something unusual is happening with this feature.

Changed in evergreen:
status: New → Confirmed
Terran McCanna (tmccanna) wrote :

I saw the behavior that Kathy is describing with one of the alerts a few days ago, but I don't recall if it was this one or not. It really looks like all of the alerts need to be reviewed for consistent behavior.

Chris Sharp (chrissharp123) wrote :

I can confirm the behavior Kathy describes.

Chris Sharp (chrissharp123) wrote :

This appears to be happening because tabbing out of a dupe-searching field into another dupe-searching field creates a new search that "overwrites" the results of the last search. If you enter dupe data into a dupe-searching field, then click into a non-dupe-searching field, the link persists and the search works as expected.

Bill Erickson (berick) wrote :

Fixes pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1723498-patron-dupe-search-clobberation

As noted in the commit, unlike the XUL client, this version shows search links per matching phone number instead of assuming the phone-based search should only search on the most recently entered phone.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.0.2
Terran McCanna (tmccanna) wrote :

Thanks, Bill! I tested against our data and it is working great.

I have tested this code and consent to signing off on it with my name, Terran McCanna and my email address, <email address hidden>.

tags: added: signedoff
Galen Charlton (gmc) on 2017-11-10
Changed in evergreen:
importance: Undecided → Medium
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Pushed to master and rel_3_0, along with a follow-up that fixes an issue with displaying the number of duplicate records. Thanks, Bill and Terran!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers