Batch Actions from Search Results

Bug #1721575 reported by Andrea Neiman on 2017-10-05
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Equinox has been contracted by MassLNC to develop a new feature for selecting records from a search & performing batch actions upon them.

Full functional specifications are here:
https://yeti.esilibrary.com/dev/public/techspecs/BatchActionsFromSearch_LP.pdf

Based on MassLNC's original requirements here:
http://masslnc.org/node/3304

Andrea Neiman (aneiman) wrote :

Highlights:

* Individual & bulk selection of search results across multiple searches
* Available in both the public OPAC as well as the embedded OPAC
* Selections to go into an expanded version of Temporary List
* Batch actions can be performed on the titles in the list, including:
  * Print title details
  * Email title details
  * Add to saved List (if logged in)
  * Add to Record Bucket (from staff client only)
  * Clear list

Galen Charlton (gmc) on 2018-05-14
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Kathy Lussier (klussier) on 2018-07-09
Changed in evergreen:
status: New → Confirmed
Galen Charlton (gmc) wrote :

A patch is available at the tip of the user/gmcharlt/lp1721575_opac_batch_actions branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1721575_opac_batch_actions

tags: added: pullrequest
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
milestone: none → 3.2-beta
Kathy Lussier (klussier) wrote :

The MassLNC Evergreen Development Initiative partners have been testing this code over the past couple of months. Our libraries are going to love the ability to select a group of items from the search results page and to place hold, add to a list, etc. in one action! Thanks Galen!

I've signed off on Galen's commit and added a small commit that changes some strings in the following ways:

1. One string on the search results page still referred to a cart. I updated it to basket.
2. In most cases when we give users the option to clear the basket after performing an action, the string says 'Clear basket after ...'. On the place holds screen, we just say 'Clear basket.' I thought it would be clearer and more consistent with the other 'clear basket' options if it said 'Clear basket after holds are requested.'

The signoff branch is at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1721575_opac_batch_actions

I held off on merging it because I would like to give an opportunity for others not involved in the project to review it.

tags: added: signedoff
Bill Erickson (berick) on 2018-08-15
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Tested all of the documented functionality (minus emailing) both in and out of the staff client. Looks great. Thanks Galen, thanks Kathy! Merged to master.

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
status: Confirmed → Fix Committed
Jane Sandberg (sandbej) wrote :

We did encounter one bug while testing this feature. Steps to recreate:

1) Add some search results to your basket within the staff client.
2) From the -- Basket Actions -- dropdown, select "Add Basket to Bucket".
3) Click cancel.
4) Click "Go".

When we followed those steps, we got the following error:

Not Found
The requested URL /eg/opac//add_cart_to_bucket was not found on this server.
Apache/2.4.7 (Ubuntu) Server at mlnc3.noblenet.org Port 443

Jane Sandberg (sandbej) wrote :

I can also open a separate bug for the Not Found error, since this feature has already been merged to master.

Andrea Neiman (aneiman) wrote :

Jane, since this is merged, I did in fact file a new bug based on what you saw -- bug 1788488. Thanks for testing!

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers