Vandelay "Export Non-Imported Records" fails in web client

Bug #1721557 reported by Remington Steed on 2017-10-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.12
Undecided
Unassigned

Bug Description

When inspecting a queue in the Marc Batch Import/Export interface (Vandelay), the "Export Non-Imported Records" feature allows a user to download a Marc file of non-imported records. This works in the XUL client, but the web staff client requires a different approach to trigger a download. Other Dojo interfaces already use the new approach, such as the Acq line item table export function. We just need to teach it to Vandelay.

Branch on the way...

Remington Steed (rjs7) wrote :
tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.0.1
Cesar V (cesardv) wrote :
tags: added: webstaffclient
tags: added: vandelay
Cesar V (cesardv) on 2017-10-06
tags: added: signedoff
Galen Charlton (gmc) on 2017-10-10
Changed in evergreen:
status: New → Confirmed
Galen Charlton (gmc) wrote :

Pushed to master and rel_3_0. Thanks, Remington and Cesar!

Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Kathy Lussier (klussier) wrote :

Since this merges cleanly into 2.12, I'm backporting this to 2.12 as well.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers