webclient: import template overwrites existing

Bug #1720002 reported by Jeanette Lundgren on 2017-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

2.12.5

Importing template file from another login overwrites existing template file instead of adding new templates.

From ADD Volumes -> Copy Templates -> Import

There is no notification to the user that the template(s) were imported.

Clicking on the template drop down list, the new template appears. Existing templates are no longer there.

We expected the imported templates to be added to the existing list.

If you click over to the Edit tab, you will see the last template applied (which is no longer in the list of templates). It is possible to apply a template in the Edit screen that no longer appears in the Copy Template tab. This is really confusing!

Elaine Hardy (ehardy) wrote :

I don't think this is a duplicate of bug #1691269. This is about what happens when templates are imported and not that they aren't showing up.

However, in 3.0.2, importing templates are not overwriting the existing list. They are adding to list as they were in the XUL client

This specific bug was addressed in the other, I just didn't realize that it was on LP already. I just added it while working on the template conversion. We had a discussion in IRC about whether or not this status should be Invalid, Fix Released, or Duplicate.

It's fixed in any case.

Jason

--
Jason Boyer
MIS Supervisor
Indiana State Library
http://library.in.gov/

> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Elaine
> Hardy
> Sent: Tuesday, February 06, 2018 9:31 AM
> To: Boyer, Jason A <email address hidden>
> Subject: [Bug 1720002] Re: webclient: import template overwrites existing
>
> **** This is an EXTERNAL email. Exercise caution. DO NOT open attachments or
> click links from unknown senders or unexpected email. ****
> ________________________________
>
> *** This bug is a duplicate of bug 1691269 ***
> https://bugs.launchpad.net/bugs/1691269
>
> I don't think this is a duplicate of bug #1691269. This is about what
> happens when templates are imported and not that they aren't showing up.
>
> However, in 3.0.2, importing templates are not overwriting the existing
> list. They are adding to list as they were in the XUL client
>
> --
> You received this bug notification because you are subscribed to
> Evergreen.
> Matching subscriptions: Evergreen Project
> https://bugs.launchpad.net/bugs/1720002
>
> Title:
> webclient: import template overwrites existing
>
> Status in Evergreen:
> New
>
> Bug description:
> 2.12.5
>
> Importing template file from another login overwrites existing
> template file instead of adding new templates.
>
> From ADD Volumes -> Copy Templates -> Import
>
> There is no notification to the user that the template(s) were
> imported.
>
> Clicking on the template drop down list, the new template appears.
> Existing templates are no longer there.
>
> We expected the imported templates to be added to the existing list.
>
> If you click over to the Edit tab, you will see the last template
> applied (which is no longer in the list of templates). It is possible
> to apply a template in the Edit screen that no longer appears in the
> Copy Template tab. This is really confusing!
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evergreen/+bug/1720002/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers