wishlist: show version information somewhere in web client

Bug #1718036 reported by Andrea Neiman on 2017-09-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

This is a recommendation that Evergreen version information be added somewhere in the web client. This could be helpful troubleshooting information to the end user.

Possible locations:
-- In Local Administration
-- In Server Administration
-- In Workstation information
-- As its own menu item under Administration

Kathy Lussier (klussier) wrote :

How about if we expand this bug to create an "About Evergreen" page that includes the version along with other information that we currently include on the "About this Client" page. It's where I typically go to find the version of other software I use. However, I'm not sure where we would put an About page, It's usually found in a Help menu, which we do not have.

Bill Erickson (berick) wrote :

+1 to About page. Maybe put the menu item in the hamburger menu (top-right), along with Log Out, etc.

Terran McCanna (tmccanna) wrote :

+1 - putting it in the hamburger menu works for me.

Another option would be to add a Help Menu that contains a link to the main documentation page and the about page. That would be a good place for libraries to add links to our own internal documentation, too.

Changed in evergreen:
status: New → Confirmed
Bill Erickson (berick) wrote :

Here's a version that creates and about page and links to it from the hamburger menu. It would be simple enough to move it to a different menu if we decide to:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1718036-webstaff-about

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.0-beta2
Changed in evergreen:
milestone: 3.0-beta2 → 3.0-rc
Kathy Lussier (klussier) on 2017-09-27
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

Thanks Bill! I like it!

I signed off on the commit, but also added a commit to add a brief description of Evergreen (culled from the Xul client's About page and the web site) as well as links to the web site, documentation and license.

Unlike the previous About page, I did not list the names of core committers or translators. If we want to acknowledge contributors in the About page, it might be worthwhile to have a discussion at a later date on who should be included.

Kathy Lussier (klussier) wrote :
Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
Bill Erickson (berick) on 2017-09-27
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Applied some minor formatting repairs, signed off, and pushed to master. Thanks, Kathy!

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
status: Confirmed → Fix Committed
Bill Erickson (berick) wrote :

Working on a follow-up patch to make the strings translatabled.

Changed in evergreen:
status: Fix Committed → Incomplete
Kathy Lussier (klussier) wrote :

Thank you Bill. Looks good to me! I merged the follow-up patch to master!

Changed in evergreen:
status: Incomplete → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers