Web Client: Make Patron Email Clickable

Bug #1717351 reported by Terran McCanna
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

We've had a request to turn the patron's email address that appears in the summary into a standard mailto: link.

(Simply wrapping it in HTML doesn't work because Angular marks it 'unsafe'.)

Revision history for this message
Shula Link (slink-g) wrote :

Confirmed that this functionality is not in the current templates. I see a possible fix, though my setup isn't currently conducive to testing.

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Shula Link (slink-g) wrote :

The issue in adding the functionality in HTML seems to come in that "mailto" is not in the $compileProvider.aHrefSanitizationWhitelist() anywhere. I can add that in and add the anchor tag to the t_summary.tt2 template and have a patch ready easily.

Revision history for this message
Galen Charlton (gmc) wrote :

Sounds like a reasonable approach; go for it, Sam!

Revision history for this message
Shula Link (slink-g) wrote :

Patch is attached!

Shula Link (slink-g)
Changed in evergreen:
assignee: nobody → Sam Link (slink-g)
Revision history for this message
Shula Link (slink-g) wrote :

Chris Sharp was kind enough to install the patch on his EG instance, and I've confirmed that the functionality has been added and have not, thus far, found anywhere it's caused issues with other modules.

tags: added: pullrequest
Revision history for this message
Shula Link (slink-g) wrote :

Branch at user/slink/lp1717351_make_patron_email_clickable

Revision history for this message
Jane Sandberg (sandbej) wrote :

Thanks for this new feature, Sam. Could you please add some brief release notes describing the feature? Here's some guidance: https://wiki.evergreen-ils.org/doku.php?id=contributing:release_notes

tags: added: needsreleasenote
Revision history for this message
Shula Link (slink-g) wrote : Re: [Bug 1717351] Re: Web Client: Make Patron Email Clickable

I pushed to user/slink/lp1717351_make_patron_email_clickable with release
notes uploaded.

Thanks!

Sam Link
Systems Librarian
Greater Clarks Hill Regional Library
<email address hidden>
<email address hidden>
706-447-6702

On Sun, Nov 5, 2017 at 5:47 AM, Jane Sandberg <email address hidden>
wrote:

> Thanks for this new feature, Sam. Could you please add some brief
> release notes describing the feature? Here's some guidance:
> https://wiki.evergreen-ils.org/doku.php?id=contributing:release_notes
>
> ** Tags added: needsreleasenote
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1717351
>
> Title:
> Web Client: Make Patron Email Clickable
>
> Status in Evergreen:
> Confirmed
>
> Bug description:
> We've had a request to turn the patron's email address that appears in
> the summary into a standard mailto: link.
>
> (Simply wrapping it in HTML doesn't work because Angular marks it
> 'unsafe'.)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evergreen/+bug/1717351/+subscriptions
>

Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master for inclusion in 3.1. Congratulations on your first contribution to Evergreen, Sam!

Changed in evergreen:
milestone: none → 3.next
status: Confirmed → Fix Committed
assignee: Sam Link (slink-g) → nobody
Galen Charlton (gmc)
Changed in evergreen:
milestone: 3.next → 3.1-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers