Allow Custom Due Dates to Persist Until Logout

Bug #1717025 reported by Jason Boyer on 2017-09-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Eg 2.12.X, 3.X

Frequently a bookmobile will visit stops on a set schedule such as every 2 or 4 weeks, etc. This can be accommodated by simply setting their circ policies to the schedule provided it doesn't change often, but in the event of an unexpected change the "Use Specific Due Date" checkbox has to be used for every user to set the new due date. It would be helpful for this and other reasons if there were an option to save and reuse the specified due date as long as the staff member is logged in. It had been my intention to get this built for the 3.0 beta but I'm hopeful it's simple enough to maybe squeak through.

Jason Boyer (jboyer) on 2017-09-14
Changed in evergreen:
milestone: none → 3.0-beta2
Jason Boyer (jboyer) wrote :

To test:
Load user
Set a custom due date in the checkout tab

Pre-patch:
Check "Use Specified Due Date" box to circ item(s) to this user due on the specified date.
Leave the user's account and return, custom due date chosen is not retained.

post-patch:
Select "Use Specified Due Date Until Logout" option from Date Options dropdown, to circ all items to this user due on the specified date.
Leave the user's account and return, custom due date is remembered.
Turning off "Use Specified Due Date Until Logout" or "Use Specified Due Date" options will cause the custom date to be forgotten on leaving user account. Only selecting "Use Specified Due Date" option behaves the same as the pre-patch checkbox.

Notes: Enabling the "...Until Logout" option forces the "Use Specified Due Date" option on; likewise, turning off the "Use Specified Due Date" option will force the "...Until Logout" option off. This allows the user to activate or deactivate the feature as intended without accidentally leaving things in an illogical state or having to make multiple selections.

Galen Charlton (gmc) on 2017-09-18
Changed in evergreen:
importance: Undecided → Wishlist
status: New → Confirmed
Galen Charlton (gmc) wrote :

This is a bit bigger than I feel comfortable squeezing into beta2, but conversely, it's small enough that as upcoming 3.0.x release maintainer I'm willing to have it go into 3.0.1 as a minor enhancement.

Cesar V (cesardv) on 2017-09-21
tags: added: webstaffclient
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Changed in evergreen:
milestone: 3.0-beta2 → 3.0-rc
Cesar V (cesardv) wrote :

Thanks Jason, I've signed off on your changes, the signoff branch is here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/jboyer_lp1717025_due_date_persist_signoff

I also added a commit on top that adds a few syntax/style cleanup type of fixes. Totally optional, but I'm a bit if a stickler when it comes to descriptive variable names for bools, and avoiding ambiguity and the like. See that commit's message for details.

Jason Boyer (jboyer) wrote :

Galen, that makes sense, glad to hear it.

Cesar, thanks for testing and offering an option on the variable names.

Galen Charlton (gmc) on 2017-09-25
Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Galen Charlton (gmc) on 2017-09-27
Changed in evergreen:
milestone: 3.0-rc → 3.0.1
Cesar V (cesardv) on 2017-10-09
tags: added: signedoff
Mike Rylander (mrylander) wrote :

Thanks, Jason and Cesar! In master and 3.0 now.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers