web client: f-key shortcuts broken

Bug #1716486 reported by Andrea Neiman on 2017-09-11
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned

Bug Description

3.0 beta

The standard f-key shortcuts in the client were previously working (as of 2.12.something) but seem to have broken in the latest iteration.

Kathy Lussier (klussier) wrote :

Confirmed for master. Shortcuts are working as expected on 2.12.5.

Changed in evergreen:
status: New → Confirmed
Kathy Lussier (klussier) wrote :

I also see the following in the Console:

angular.js:14199 ReferenceError: route is not defined
    at callback (navbar.js:35)
    at c (hotkeys.min.js:7)
    at hotkeys.min.js:7
    at m.$eval (angular.js:17994)
    at m.$apply (angular.js:18094)
    at hotkeys.min.js:7
    at l (hotkeys.min.js:7)
    at p.s._handleKey (hotkeys.min.js:7)
    at p.handleKey (hotkeys.min.js:7)
    at HTMLDocument.m (hotkeys.min.js:7)
(anonymous) @ angular.js:14199
(anonymous) @ angular.js:10707
$apply @ angular.js:18099
(anonymous) @ hotkeys.min.js:7
l @ hotkeys.min.js:7
s._handleKey @ hotkeys.min.js:7
p.handleKey @ hotkeys.min.js:7
m @ hotkeys.min.js:7

Kathy Lussier (klussier) wrote :

I'm going to set the priority to High on this one because we will face real challenges in getting staff to use the web client without the keyboard shortcuts.

Changed in evergreen:
importance: Medium → High
Galen Charlton (gmc) on 2017-09-13
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

A patch is available at the tip of the user/gmcharlt/lp1716486_fix_hotkeys branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1716486_fix_hotkeys

tags: added: pullrequest
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Janet Schrader (jschrader) wrote :

Kathy, this depends on what screen you're on or where the cursor is. I'm using chrome and web 2.12.5.
The shortcut keys do not work depending on what screen you're on. They work as long as you are not in a search screen, or if you are, as long as the cursor is not in a search field. If you hit F5 on the home screen, regardless of where the cursor is, you'll get item status. If you're on the basic search screen and hit F5 you get the advanced search screen, here if you hit F5 the screen refreshes. The same is true with browse the catalog search screen. On search screens, F5 acts the same as refresh.

If you are in circulation functions the shortcut keys work. For catalogers there's a problem as much of their work involves search screens.

Kathy Lussier (klussier) wrote :

Hi Janet,

The problem doesn't manifest until 3.0. In 2.12, they work as expected. IIRC, they don't work in an iframe, which includes the catalog screens and any of the Dojo screens, including Vandelay, acquisitions screens, etc.

Kathy

Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

It works for me. Pushed to master.Thanks Galen!

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers