Complain if minimum Pg version for 3.0 is not met

Bug #1715503 reported by Galen Charlton on 2017-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Evergreen 3.0's installation and upgrade scripts should complain if the version of PostgreSQL supplied is less than 9.4.

Points where this could happen include:

- eg_db_config.pl
- the monolithic 2.12.x to 3.0.0 database upgrade script

Galen Charlton (gmc) on 2017-09-06
Changed in evergreen:
milestone: none → 3.0-beta2
importance: Undecided → Medium
Jason Boyer (jboyer) wrote :

*Looks around, whistles, tries to look inconspicuous.*

Jason Stephenson (jstephenson) wrote :

The README in master still says that 9.3 is the minimum supported version. That should be changed also.

Galen Charlton (gmc) on 2017-09-20
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

A set of patches is available in the user/gmcharlt/lp1715503_enforce_pg_94_as_minimum branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1715503_enforce_pg_94_as_minimum

tags: added: pullrequest
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Mike Rylander (mrylander) wrote :

Merged to master for beta-2 goodness. Thanks, Galen!

Changed in evergreen:
status: New → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers