Web Client: patron ID values not shown in patron summary

Bug #1715423 reported by tji@sitka.bclibraries.ca on 2017-09-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
2.12
Low
Unassigned

Bug Description

In patron summary, labels are displayed for ID fields. Primary ID Type is shown, but ID value is not. Secondary ID is not shown.

Andrea Neiman (aneiman) wrote :

Confirmed, 3.0 beta (web client).

In XUL, ID value is displayed (partially obscured) below the ID 1 field in the sidebar.

Web client appears to have no place for ID value to display in the sidebar (which may be intentional, as this could be considered sensitive information?)

I could not get anything to display in the web client sidebar field ID2 regardless of what I entered in the Secondary Identification field (in XUL this was labelled Parent/Guardian in the form but displayed with ID2 in the sidebar).

tags: added: web
tags: added: webstaffclient
removed: web
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Low
Bill Erickson (berick) wrote :

I believe this is an oversight and not a privacy measure.

Note the XUL client is displaying the full, unobscured ID values for me in the default vertical display mode.

Cesar V (cesardv) on 2017-09-27
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Cesar V (cesardv) wrote :

The display of the patron IDs was a bit messed up. The following branch tries to address those issues

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1715423_webstaff_patron_summary_ID_rows

tags: added: pullrequest
Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Mike Rylander (mrylander) wrote :

Pulled into master. I'll leave this out of 3.0 for now, as it's not targeted.

Changed in evergreen:
status: Confirmed → Fix Committed
Kathy Lussier (klussier) on 2017-10-20
Changed in evergreen:
milestone: none → 3.next
Kathy Lussier (klussier) wrote :

Since this appears to fall under the definition of bug fix, I've backported it to 3.0 and 2.12. I'll update the targets accordingly once I create new milestones for 2.12.8 and 3.0.2.

Changed in evergreen:
milestone: 3.next → 3.0.2
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers