lp1629108_metarecord_constituent_result_reroute.pg test failure

Bug #1714594 reported by Galen Charlton on 2017-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

The test Open-ILS/src/sql/Pg/t/regress/lp1629108_metarecord_constituent_result_reroute.pg can fail intermittently:

1..2
ok 1 - Generic check for unapi.mmr_mra breakage
not ok 2 - unapi.mmr_mra results have source_list="242,243,244sfaf"
# Failed test 2: "unapi.mmr_mra results have source_list="242,243,244sfaf""
# have: false
# want: true
# Looks like you failed 1 test of 2
Failed 1/2 subtests

Test Summary Report
-------------------
Open-ILS/src/sql/Pg/t/regress/lp1629108_metarecord_constituent_result_reroute.pg (Wstat: 0 Tests: 2 Failed: 1)
  Failed test: 2

Also, it has a copy of unapi.mmr_mra() that's not needed in the context of a regression test.

Galen Charlton (gmc) on 2017-09-01
Changed in evergreen:
milestone: none → 3.0-alpha
importance: Undecided → Medium
tags: added: pullrequest
Galen Charlton (gmc) wrote :

A patch is available in the user/gmcharlt/lp1714594_fix_test_case branch.

Galen Charlton (gmc) wrote :

After some discussion with Blake, I'm going to go ahead and push this, but some additional work would be a good idea to make this test less sensitive on the dataset.

Changed in evergreen:
status: New → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers