Web Client: Patron Registration not honoring Password from Phone Number

Bug #1714060 reported by Terran McCanna on 2017-08-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.12
Medium
Unassigned

Bug Description

In 2.12.4:

The patron registration form is not honoring the setting for "Patron: password from phone #" (patron.password.use_phone)

Kathy Lussier (klussier) wrote :

This worked in an early version of the Angular patron editor. I noticed that when I enter the phone number in the daytime phone field, I get the following in the Console:

angular.js:14199 ReferenceError: phone is not defined
    at m.$scope.handle_field_changed (regctl.js:1704)
    at fn (eval at compile (angular.min.js:1), <anonymous>:4:383)
    at b (angular.js:16213)
    at e (angular.js:26592)
    at m.$eval (angular.js:17994)
    at m.$apply (angular.js:18094)
    at HTMLInputElement.<anonymous> (angular.js:26597)
    at HTMLInputElement.dispatch (jquery.min.js:3)
    at HTMLInputElement.r.handle (jquery.min.js:3)

Changed in evergreen:
status: New → Confirmed
tags: added: regression
Changed in evergreen:
importance: Undecided → Medium
Cesar V (cesardv) on 2017-09-28
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Cesar V (cesardv) wrote :

The following branch fixes the thinko that resulted in the error Kathy described above:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1714060-bug_in_patron_reg_patron.password.use_phone

To test simply:
1. Apply patch.
2. Register (new) Patron
3. Enter a Day Phone for said new patron.
4. Use the Test Password screen to verify password is last 4 of day phone.

Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
tags: added: pullrequest
Mike Rylander (mrylander) wrote :

Picked into master, and 3.0 since it's a simple, obvious fix. Thanks, Cesar!

Changed in evergreen:
milestone: none → 3.0.1
status: Confirmed → Fix Committed
Kathy Lussier (klussier) wrote :

Since this fix merges cleanly to 2.12, I've backported there as well. Thanks Mike and Cesar!

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers