Web Client: Require dob field not honored

Bug #1714056 reported by Terran McCanna on 2017-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.12
Medium
Unassigned

Bug Description

In the 2.12.4 web client:

I have "Require dob field on patron registration" set to 'true' but the web client allows me to create new patrons and edit existing patrons without requiring a dob entry.

It does not appear in yellow as other required fields do.

If I click "Show: Required Fields" it shows the dob field regardless of whether I've marked it required or not.

Changed in evergreen:
status: New → Confirmed
Cesar V (cesardv) on 2017-10-03
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Terran McCanna (tmccanna) wrote :

Still broken in 3.0.0

Cesar V (cesardv) wrote :

Easiest way to test would be to (1) check the setting is set to true, (2)apply the patch, (3) verify the DOB field is required in order to create new patron. (4) remove setting, and test that it's no longer required.

Terran McCanna (tmccanna) wrote :

I have tested this code and consent to signing off on it with my name, Terran McCanna and my email address, <email address hidden>.

tags: added: signedoff
Mike Rylander (mrylander) wrote :

Picked into master and 3.0. Thanks!

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: none → 3.0.1
Kathy Lussier (klussier) wrote :

Since this fix merges cleanly into 2.12, I've backported it there as well.

Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
importance: Undecided → Medium
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers