Web Client: Default Hold Pickup Location Errors

Bug #1712637 reported by Terran McCanna on 2017-08-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
2.12
High
Unassigned

Bug Description

In 2.12.4 web client:

Two problems with the Default Hold Pickup Location field on the patron registration/edit form.

First, changing the value of the Default Hold Pickup Location changes the value of the Home Library.

Second, the Default Hold Pickup Location allows selection of org units such as system or consortium that are not viable pickup locations.

tji@sitka.bclibraries.ca (tji) wrote :

The list also includes those libraries marked non-pickup library via library setting: OPAC: Org Unit is not a hold pickup library. But these libraries are greyed out on the pickup library list on Place Hold screen. This behaviour is the same as on XUL client.

Kathy Lussier (klussier) on 2017-09-11
Changed in evergreen:
status: New → Confirmed
Kathy Lussier (klussier) wrote :

About issue #2.

Is the pickup library dropdown used on the record View Holds tab the same that is used in the patron editor? If so, I just wanted to add a comment that we've seen some value in making the system and consortium selectable in that interface since it allows a system, for example, to see the holds in all of its branches. When this bug is fixed, it would be great if we could maintain the ability to select those parent OUs on this particular screen while disabling them in the patron editor.

Kathy Lussier (klussier) wrote :

Setting this bug to High since the change made to the Home Library will be very problematic for libraries.

Changed in evergreen:
importance: Undecided → High
milestone: none → 3.0-beta2
Bill Erickson (berick) on 2017-09-14
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Fixes pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1712637-webstaff-def-pickup-loc

In addition to fixing the basic behavior, the patch replicates the XUL client like so:

1. No value is applied unless staff set one.

2. Org units with "can_have_vols" set to false are disabled in the selector.

3. Re: comment #1 above, no attempt is made to disable org units with the "OPAC: Org Unit is not a hold pickup library" library setting applied, as this would be a change of behavior. Also, the purpose of this setting as I understand it is only to affect the catalog.

tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Kathy Lussier (klussier) on 2017-09-15
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

I applied the patch. Selecting a pickup library no longer changes the home library for the patron. However, I'm still able to select a system or a consortium as the holds pickup location, even though the can have volumes setting is false for those org unit levels.

Kathy Lussier (klussier) on 2017-09-18
Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
Kathy Lussier (klussier) wrote :

The previous issue was due to what appears to be a partial application of the patch. After re-loading the patch, it works as expected. Merged to master and release 2.12.

Thank you Bill!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers