Web Client: Patron Search by Email Not Working as Expected

Bug #1712628 reported by Terran McCanna on 2017-08-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

In 2.12.4 - I can no longer search by complete email address in either the xul client or the web client. I can search for the first part of the email address only.

tmccanna - good results
<email address hidden> - zero results
georgialibraries.org - zero results
mccanna - zero results

Terran McCanna (tmccanna) wrote :

This is also broken when registering a new patron and checking for duplicate emails.

If I type in the first part (tmccanna) it does the check and finds the dups (<email address hidden>) but if I type in the full email address (<email address hidden>) it does not find any duplicates.

Terran McCanna (tmccanna) wrote :

It looks like it's actually cutting off at the first non-alphanumberic character.

Example: "<email address hidden>"
Searching <email address hidden> = zero results
Searching angela.smith = zero results
Searching angela = result

Cesar V (cesardv) wrote :

Just FYI - I've tested in the latest working master, and 2.12.1 and could not exactly replicate Terran's same results.

It seems the patron email search is left anchored, thus for example:

- for patron a patron with email address "<email address hidden>"
- You can get results if you search "the" "the.gov" or the any subset of the email string starting from the left.
- I did get results for a whole email address, with dots, dashes, plus-signs and underscores.
- Unfortunately, searching for "governator" however, won't yield any results, and this seems to be due to implementation.

Andrea Neiman (aneiman) wrote :

3.0 beta, web client & XUL

I am seeing the same behavior Cesar describes with left-anchored searching. To Concerto patron Melvin Neal I added the email "<email address hidden>".

Any left-anchored subset of the string gets expected results.

In the web client, I get the duplicate email flag when I enter the entire email into a new patron form, though I don't get a flag for any subsets of the email.

In the XUL client, I get the duplicate email flag if I enter any left-anchored subset of the email, or the full email.

I seem to recall that email search was always left-anchored, but I've asked someone else to test on some earlier XUL systems.

Also, IMO there isn't a lot of use for the duplicate check mechanism to look for subsets of an email but I could be convinced otherwise.

Terran McCanna (tmccanna) wrote :

Also confirmed this is working again in 3.0 release candidate. I'll mark this Fixed.

Changed in evergreen:
status: New → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers