Conjoined items do not display unless there are two or more in a set

Bug #1712362 reported by Dan Scott
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
2.12
Undecided
Unassigned

Bug Description

* Evergreen master / 3.0 / 2.12

Even though this sounds like #1703678 "Conjoined items do not display without an extra copy attached to the record", it is different.

Test case:

1. Add a single record (say ID 1234) as a peer to another record (say ID 1000).
2. Display record 1234. It will show that record 1000 is the set to which it belongs under the "foreign item" heading below the normal copy display.
3. Display record 1000. Under the normal copy display, it will not show that it contains a foreign item.

This is the result of an off-by-one error in the copy_table.tt2 template; to fix it, we change:

[%- IF copy_info.peer_bib_marc.size > 1;

to:

[%- IF copy_info.peer_bib_marc.size > 0;

Once the fix is in place, record 1000 will link to record 1234 in the list of set items.

Revision history for this message
Dan Scott (denials) wrote :
tags: added: pull
tags: added: pullrequest tpac
removed: pull
Changed in evergreen:
milestone: none → 3.0-alpha
no longer affects: evergreen/2.11
Changed in evergreen:
assignee: nobody → Mike Rylander (mrylander)
Revision history for this message
Mike Rylander (mrylander) wrote :

Picked into master and 2.12, where it merges cleanly.

Thanks, Dan!

Changed in evergreen:
status: New → Fix Committed
assignee: Mike Rylander (mrylander) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers