Web Staff Client: Missing courier code on transit slip print templates

Bug #1708485 reported by Terran McCanna on 2017-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
2.12
High
Unassigned

Bug Description

The Transit Slip and Hold Transit Slip print templates don't appear to have access to the destination courier code field.

This was available as a macro in the xul client (%courier_code%) and it's crucial for PINES.

Terran McCanna (tmccanna) wrote :

This is a showstopper for PINES - we can't pilot this in a live environment until we have the courier code available.

Changed in evergreen:
importance: Undecided → High
Chris Sharp (chrissharp123) wrote :

Bill Erickson helped Terran and me get this going. Branch here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/csharp/lp1708485_add_courier_code_transit_slips

Tested with real PINES™ data.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.0-alpha
Terran McCanna (tmccanna) wrote :

Thank you Bill and Chris!!!!!

Terran McCanna (tmccanna) wrote :

Note: With this patch, dest_courier_code works when printing, but it doesn't show up in the preview - I'm not sure what it would take to make that happen.

Kathy Lussier (klussier) on 2017-08-23
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

I tried this patch, but I was unable to get the courier code to print on the slip. I used {{dest_courier_code}} in the print template for both the holds transit and transit slips, but I didn't have luck with either one.

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
Galen Charlton (gmc) wrote :

I've written a follow-up patch that

- ensures that dest_courier_code is available to the print template
- displays the courier code, if defined, on the routing dialog
- updates the inline printer template documentation

New branch is user/gmcharlt/lp1708485_signoff

tags: added: signedoff
Galen Charlton (gmc) on 2017-08-23
Changed in evergreen:
status: New → Confirmed
Terran McCanna (tmccanna) wrote :

Thank you, Galen!

Kathy Lussier (klussier) wrote :

Works for me! Merged to master and release 2.12.

Thank you Galen, Chris and Terran!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers