Check Number in Bill History

Bug #1705693 reported by Scott Thomas on 2017-07-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

In Bill History, the column picker in both the Transactions and Payments tab does not allow you to select Check Number so Check Number cannot be displayed. We are at 2.11.4.

Kathy Lussier (klussier) wrote :

Confirming that check number is not a column picker option in Bill History in either the xul or web client.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Wishlist
Michele Morgan (mmorgan) on 2019-04-19
tags: added: webstaffcolumns
Gina Monti (gmonti90) wrote :

Feedback Fest 2/8/2021 comment:

Is this patch supposed to be only applied to "Payments" tab in Bill History?

Terran McCanna (tmccanna) wrote :

It looks like the code was changed for both Payments and Transaction Details

Terran McCanna (tmccanna) wrote :

Ah, not Bills > History > Transactions, though.

Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
Terran McCanna (tmccanna) wrote :

Upon considering this further, I'm not sure that it really makes sense to have check number in the transaction history tab -- a transaction can have multiple payments, in which case there can be multiple check numbers.

Double-clicking on the transaction opens the bill details, where all of the payments in the transaction with their check numbers ARE displayed with this patch. So, I'm going to go ahead and sign off on this patch because it's a useful improvement as-is:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mccanna/lp_1705693_check_number_bill_history_signoff

If anyone thinks that either *all check numbers* or *last check number* should be added to the Bills > History > Transactions tab, please create a new wish list ticket and specify your preference between the two.

tags: added: signedoff
Changed in evergreen:
assignee: Terran McCanna (tmccanna) → nobody
Michele Morgan (mmorgan) on 2021-02-17
Changed in evergreen:
milestone: none → 3.7-beta
Galen Charlton (gmc) wrote :

Pushed to master for inclusion in 3.7. Thanks, Dan and Terran!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers