webclient: cannot edit MARC records from MARC Batch Import/Export (Vandelay)

Bug #1700635 reported by Andrea Neiman on 2017-06-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Within the MARC Batch Import/Export interface, you can view & edit a MARC record in your queue by clicking the "View MARC" link in the queue, and then "Edit" in the resulting screen. In XUL client, this will open a new window with the MARC Edit interface and you can edit/save as expected.

This is not working correctly in Webby.

In Chrome, a new (blank) browser window opens and downloads a file named marcedit.xul

In Firefox, you get a new browser window with the address https://webby.evergreencatalog.com/xul/server/cat/marcedit.xul and an error stating "This page uses an unsupported technology that is no longer available by default in Firefox."

Windows 10/Chrome 58/Firefox 54
EG 2.12

Andrea Neiman (aneiman) on 2017-06-26
description: updated
Galen Charlton (gmc) wrote :

For whoever takes this up, commit 0bd63e583da386f gives an example of a way to deal with it.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 3.0-alpha
Changed in evergreen:
milestone: 3.0-beta → 3.0-beta2
Galen Charlton (gmc) on 2017-09-11
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Cesar V (cesardv) wrote :

A branch that add the ability to edit the marc record using the modal MarcEditor is here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1700635-vandelay_bib_queue_edit_marc_redo

tags: added: pullrequest
Galen Charlton (gmc) on 2017-09-20
Changed in evergreen:
assignee: Cesar V (cesardv) → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Tested and works for me and merged to master for inclusion in beta2. Thanks, Cesar!

From the amended commit message:

    Note that this patch doesn't ensure that the modal can save the
    record and be dismissed via just a single click of the Modify button;
    an issue was discovered with that that could not be resolved in time
    for beta2.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers