Barcode completion does not work in web client

Bug #1699566 reported by Jeff Davis on 2017-06-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
2.12
High
Unassigned

Bug Description

EG 2.12

The web client allows you to configure barcode completion settings. However, those settings appear to be completely ignored when entering user and item barcodes in the web client. These barcodes should auto-complete when barcode completion rules apply.

Michele Morgan (mmorgan) wrote :

In the web client on a 2.12.2 system, I am finding that barcode completion is working fine for patron barcodes, but not for item barcodes.

For barcode completion configurations set as follows:

Active: True
Prefix: 33011
Suffix:
Length: 14
Padding: 0
Padding At End:
Applies to Items: True
Applies to Users: False

Active: True
Prefix: 23011
Suffix:
Length: 14
Padding: 0
Padding At End:
Applies to Items: False
Applies to Users: True

A patron with barcode 23011000004259 is retrieved at checkout by entering 4259

An item with barcode 33011000004240 is NOT retrieved at checkout or in item status by entering 4240

Changed in evergreen:
status: New → Confirmed
importance: Undecided → High
Galen Charlton (gmc) on 2017-06-28
Changed in evergreen:
milestone: none → 3.0-alpha
Galen Charlton (gmc) wrote :

Some calls to open-ils.actor.get_barcodes needed; Open-ILS/web/js/ui/default/staff/cat/item/missing_pieces.js has an example of a web staff interface that /does/ do barcode completion for copies.

Galen Charlton (gmc) wrote :

Also, in addition to the interfaces that Michele identified as not doing completion for copy barcodes, the copy buckets barcode input currently lacks that as well.

Andrea Neiman (aneiman) on 2017-07-06
tags: added: webstaffclient
Changed in evergreen:
assignee: nobody → Jeff Davis (jdavis-sitka)
Jeff Davis (jdavis-sitka) wrote :

Branch user/jeffdavis/lp1699566-item-barcode-completion-squashed in the working repo adds barcode completion in checkout/renew, checkin, and item status in the web client:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=856720b

This adds a handle_barcode_completion function to the egCirc service. It handles multiple matching barcodes in the same manner as the XUL client.

I'm not sure where the copy buckets barcode input is, but it should be easy enough to use the new function there too.

tags: added: pullrequest
Kathy Lussier (klussier) on 2017-08-23
Changed in evergreen:
assignee: Jeff Davis (jdavis-sitka) → nobody
Kathy Lussier (klussier) on 2017-08-23
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Jeff Davis (jdavis-sitka) wrote :

Working branch user/jeffdavis/lp1684988-web-client-opt-in-2.12 has a fix for EG 2.12:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=c77c33ab

Jeff Davis (jdavis-sitka) wrote :

Whoops, wrong ticket, sorry.

Kathy Lussier (klussier) wrote :

Thank you Jeff. Barcode completion works for me in check in, check out, renew, and item status interfaces.

While testing, I discovered another issue where the check in, check out, and renew screens display the partial, scanned barcodes in grids instead of the full, real barcode. The item statu screen displays the full barcode as expected. I'll post a follow-up bug on that issue.

I've merged Jeff's code to master and, after resolving a merge conflict, to release 2.12.

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
status: Confirmed → Fix Committed
Kathy Lussier (klussier) wrote :

Reopening this bug for 2.12 because a bad resolution to a merge conflict with the 2.12 branch broke the build for 2.12. A branch from Jeff Davis and signed off by Jason Stephenson is available at user/dyrcona/lp1699566-barcode-completion-fix_2_12_signoff.

Testing the fix now.

Changed in evergreen:
status: Fix Committed → Fix Released
Jeff Davis (jdavis-sitka) wrote :

The fix here only addresses item barcode completion. For patron barcode completion (specifically handling multiple matches), see bug 1721610.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers