webclient wishlist: wrap long fields in MARC editor

Bug #1691263 reported by Andrea Neiman
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.12
Medium
Unassigned
3.0
Medium
Unassigned

Bug Description

In the web staff client, fields containing a lot of text (such as 5xx fields) can extend off of the visible area of the browser. While you can scroll the browser horizontally to see the remainder of the text, it might be helpful to have the MARC editor wrap text to the width of the browser window.

Marking confirmed as it was initially reported by Angela Kilsdonk & confirmed by me.

EG 2.12

Andrea Neiman (aneiman)
Changed in evergreen:
status: New → Confirmed
Revision history for this message
Galen Charlton (gmc) wrote :

This straddles the border between a UX bug and a wishlist; I'm electing to call it a bug for now. A two-patch series is available at the tip of the user/gmcharlt/lp1691263_marc_editor_wrapping branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1691263_marc_editor_wrapping

Changed in evergreen:
importance: Undecided → Medium
milestone: none → 3.0.4
tags: added: pullrequest
Changed in evergreen:
milestone: 3.0.4 → 3.0.5
Revision history for this message
Kathy Lussier (klussier) wrote :

Thanks Galen and Cesar! I loaded this code on a test VM, and the wrapping looks good.

However, I noticed some weirdness in the holdings view of the record. I've attached a screenshot of what I'm seeing when I look at holdings view for record 210 in the Concerto dataset. I also loaded a clean master system and did not see this same weirdness.

Also, I don't think this is should stop the code from going in, but we noticed that there is now some spacing between the subfield and text that didn't display before. I was playing around with the CSS to see if I could remove it (it just looks a little cleaner without it), but I didn't have much luck. Do you have any thoughts on why this might be happening?

Revision history for this message
Kathy Lussier (klussier) wrote :
Revision history for this message
Kathy Lussier (klussier) wrote :

Forgot to add a needsrepatch tag to this one. Doing so now.

tags: added: needsrepatch
removed: pullrequest
Revision history for this message
Kathy Lussier (klussier) wrote :

Re-adding the pullrequest tag on this one. I reloaded the VM with vanilla master and continue to see the strange display in Holdings View. Since I didn't see this issue on another VM, I'm going to investigate local storage settings to see if they might be a factor. Either way, the patch should be fine.

tags: added: pullrequest
removed: needsrepatch
Revision history for this message
Elaine Hardy (ehardy) wrote :

Kathy,

We put this on our test server. Everything looks fine and I a not seeing the holdings issue you had.

Revision history for this message
Kathy Lussier (klussier) wrote :

Sigh...this was just user error. If you look at the screenshot, I have the 'show copy details' and 'show volume details' deselected. I'm pretty sure I've made this mistake before.

I'll sign off on the patch. I'm in agreement with Galen that this can be treated as a UX bug fix. Dan, do you have any concerns about me backporting this fix to 3.1?

Revision history for this message
Kathy Lussier (klussier) wrote :

I've merged the patch to master for inclusion in 3.1RC and also backported it to 3.0 and 2.12.

Thank you Cesar, Galen and Elaine!

Kathy

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: 3.0.5 → 3.1-rc
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers