Exclude Electronic Resources cannot be un-selected with advanced search filters applied

Bug #1690468 reported by Jeff Davis on 2017-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.0
Undecided
Unassigned

Bug Description

Evergreen 2.12.1

Once checked, the Exclude Electronic Resources box on search results cannot successfully be unchecked if advanced search filters have been applied.

1. Enable the "Exclude Electronic Resources" checkbox in config.tt2.

2. Do an advanced search, applying at least one search filter (e.g. Language = "English").

3. On the search results page, check the Exclude Electronic Resources checkbox. The page reloads, repeating your search with e-resources excluded from results.

4. Uncheck the Exclude Electronic Resources checkbox.

Expected behavior: The results page re-loads, e-resources are included in results again, and the checkbox is unchecked.

Actual behavior: When the results page re-loads, e-resources are still excluded from results, and the Exclude Electronic Resources box is still checked.

(This is a separate issue from bug 1679309, but presumably related.)

Jeff Davis (jdavis-sitka) wrote :

Branch user/jeffdavis/lp1690468-exclude-electronic-resources-with-advanced-search-limiters of the working repo contains a fix:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=5a54d94a

tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.12.2
Kathy Lussier (klussier) on 2017-05-19
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) on 2017-05-19
Changed in evergreen:
status: New → Confirmed
Kathy Lussier (klussier) wrote :

Thank you for catching this one Jeff! Your fix works for me. I've signed off on the commit and merged it to master and release 2.12.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Kathy Lussier (klussier) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers