Z39.50 server / SuperCat CQL parser ignores bools

Bug #1687649 reported by Bill Erickson on 2017-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
2.11
Low
Unassigned

Bug Description

Evergreen 2.12 / all versions

SuperCat CQL parser (effectively) ignores @or and @and boolean fields when compiling CQL queries for Z39.50 server searches.

To reproduce in yaz-client -- assuming Z39 on localhost with database name 'evergreen' and concerto data set:

Z> open localhost:2210/evergreen
Connecting OK...
...
Z> find @or @attr 1=4 @attr 4=6 "potter" @attr 1=4 @attr 4=6 "piano"
...
Number of hits: 0, setno 1

This should compile down to => title:potter || title:piano

The "Number of hits" value should be 38 (with current concerto).

Patch en route.

Bill Erickson (berick) wrote :

Thanks to Mike for pointing me in the right direction on this one!

Fix pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1687649-z39-bools

To confirm the fix, the above steps should return a non-zero result for the number of hits. Also, the opensrf logs should contain a line like so:

SRU search string [(title = potter or title = piano)] converted to [title:potter || title:piano]

tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.12.2
assignee: Bill Erickson (berick) → nobody
Galen Charlton (gmc) wrote :

Works for me! Signoff branch is user/gmcharlt/lp1687649_signoff

tags: added: signedoff
Galen Charlton (gmc) on 2017-05-04
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Low
Galen Charlton (gmc) wrote :

Pushed to master, rel_2_12, and rel_2_11. Thanks, Bill!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers