webclient: no automatic refresh after adding or editing copies & volumes

Bug #1684202 reported by Andrea Neiman on 2017-04-19
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Undecided
Unassigned
3.1
Medium
Unassigned

Bug Description

2.12 Web staff client

If you add or edit copies and/or volumes from the Holdings View tab, the view does not automatically refresh to show your additions or changes.

If you refresh the browser, you are taken back to whichever tab is your default view. If you then click over to Holdings View you can see the additions/changes reflected.

Kathy Lussier (klussier) on 2017-05-09
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Changed in evergreen:
assignee: nobody → Skye Howard (showard1110)
Skye Howard (showard1110) wrote :

So to clarify - is this when it opens a new window, specifically when you use the Actions -> Edit (or add) -> Copies / Volumes actions and the user finishes editing / adding and saves and the temporary window is now closed, is the expectation that the original window will refresh to reflect the changes from the other window?

Kathy Lussier (klussier) wrote :

Hi Skye,

Yes, exactly. I've shared a screencast showing the existing behavior in the old client that we would like to see in the xul client.

https://drive.google.com/file/d/0B74gDMUDwDXqUllKdWdmdnVJQ2c/view

Whenever we perform one of the following actions from the Actions menu, we were are done adding or editing the item, we would like to return to Holdings View in the same way with the updated information displaying.

- Add Copies
- Add Volumes and Copies
- Edit Volumes
- Edit Copies
- Edit Volumes and Copies
- Replace Barcodes

Jason Stephenson (jstephenson) wrote :

Skye,

Are you still working on this? If not, I'd like to take it over or assign it to someone who works with me.

Jason

Feel free to take it over! I had no idea I still had any bugs assigned to
me; I have been reassigned to another contract. If you want to contact
someone with our org feel free to check in with Kyle Huckins, or feel free
to take it on yourself Thanks!

On Fri, Apr 6, 2018 at 1:30 PM, Jason Stephenson <<email address hidden>
> wrote:

> Skye,
>
> Are you still working on this? If not, I'd like to take it over or
> assign it to someone who works with me.
>
> Jason
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1684202
>
> Title:
> webclient: no automatic refresh after adding or editing copies &
> volumes
>
> Status in Evergreen:
> Confirmed
>
> Bug description:
> 2.12 Web staff client
>
> If you add or edit copies and/or volumes from the Holdings View tab,
> the view does not automatically refresh to show your additions or
> changes.
>
> If you refresh the browser, you are taken back to whichever tab is
> your default view. If you then click over to Holdings View you can
> see the additions/changes reflected.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evergreen/+bug/1684202/+subscriptions
>

Changed in evergreen:
assignee: Skye Howard (showard1110) → nobody
Cesar V (cesardv) on 2018-08-15
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Cesar V (cesardv) wrote :

Here's a branch for a way to auto-refresh the holdings grid upon a child volcopy editor tab s"aving and exiting." Implemented using the native browser BroadcastChannel API, so should work fine on any recent Firefox and Chrome.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1684202-bChannel_refresh_holdings_onvolcopy_tabsave

tags: added: pullrequest
Andrea Neiman (aneiman) on 2018-09-14
Changed in evergreen:
milestone: none → 3.2-rc
Mike Rylander (mrylander) wrote :

I've pushed a branch that aligns the use of Broadcast Channel with how the auth code is using it, both by protecting browsers that don't support BC and by changing the channel name. It's also passing back more info, including the full list of bib IDs and call number IDs that were presented to the interface, in case other consumers might want to make use of them.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/miker/lp1684202-bChannel_refresh_holdings_onvolcopy_tabsave

Joan Kranich (jkranich) wrote :

Evergreen release 3.0.11 on a test server with a few other patches
Browser Chrome

I tested Edit Volumes and Copies from the Holdings View screen.
I changed the Shelving Location.
Clicked Save & Exit.
The screen returned to Holdings View and displayed the updated Shelving Location.

I tested again after the update in comment #6 was added to the test server.
After taking the same steps noted above the screen returned to Holdings View but did not display the updated Shelving Location. The former Shelving Location still displayed.

Cesar V (cesardv) on 2018-09-14
Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Meg Stroup (mstroup) wrote :

Another confirmation:

Using MOBIUS sandbox and Chrome:

- went to holdings view, then edit volumes/copies [new window opens]
- changed a shelving location
- chose Save & Exit [temporary window closes automatically]

Updated shelving locations are displayed without refreshing screen.

Kathy Lussier (klussier) wrote :

Adding a note that I also tested the branch with both commits from Cesar and Mike. As Joan reported, I am not seeing the updated copy location in holdings view after saving my changes. I also see the following in the browser console:

Uncaught TypeError: e.data.records.contains is not a function
    at BroadcastChannel.holdings_bChannel.onmessage (app.js:1095)

Mike Rylander (mrylander) wrote :

Kathy, that's because I typed "contains" rather than "includes". I'm honestly not sure how I managed that, as I was staring at the documentation when I changed the code, but a fix for that is forthcoming.

Kathy Lussier (klussier) wrote :

I added Mike's new branch to a test server. When I add a new call number and item from holdings view and then save the item, the screen refreshes as expected and shows the new call number and item.

If I edit an item to give it a new shelving location and then save the record, the screen does not refresh to show the new shelving location. There are no error messages in the Console.

Changed in evergreen:
milestone: 3.2-rc → 3.2.1
Elaine Hardy (ehardy) wrote :

Chris applied patch to PINES test server. I did not see a refresh when editing a copy, adding copies or adding vols/copies.

Kathy Lussier (klussier) on 2018-10-16
tags: added: needsrepatch
removed: pullrequest
Cesar V (cesardv) wrote :

The latest branch still had a small bug that was preventing a the refresh from taking place. I blame javascript's random implicitly conversion rules... Anyways here's a branch, now bug-free!

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1684202-bChannel_refresh_holdings_onvolcopy_tabsave-fixed2

Kathy, Elaine could you please give this another test?

Cesar V (cesardv) on 2018-10-18
tags: added: pullrequest
removed: needsrepatch
Changed in evergreen:
milestone: 3.2.1 → 3.2.2
Elaine Hardy (ehardy) wrote :

Auto refreshes works when editing item but not for adding new items

Cesar V (cesardv) wrote :

Thanks for testing this Elaine, can you pull in the latest from the last branch (http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1684202-bChannel_refresh_holdings_onvolcopy_tabsave-fixed2) and give it a test again? I fixed yet another javascript quirk...

Elaine Hardy (ehardy) wrote :

Cesar -- sorry I missed this. I will ask Chris to update. He is in the middle of scripting something really complicated so may not have a chance to get to this today.

Chris Sharp (chrissharp123) wrote :

Works for us! Pushed to master, rel_3_1 and rel_3_2. Thanks, Cesar and Mike!

Changed in evergreen:
status: Confirmed → Fix Committed
tags: added: signedoff
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers