web client: Scanning non-existent items at item status fails without feedback to the user

Bug #1683575 reported by Kathy Lussier on 2017-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned

Bug Description

Evergreen version: master as of 4/17. This feature works as expected in 2.12.

As previously reported by Jason Etheridge in bug 1528924, with the addition of the code from that bug, we no longer get an alert when scanning a non-existent barcode in the item status screen. Expected behavior is to receive an alert that says the copy is mis-scanned or is not cataloged.

Marking as confirmed since Jason originally reported the bug and I've replicated the problem.

Andrea Neiman (aneiman) wrote :

Kathy -- do you mean scanning in item status? Bug 1528924 is referring to item status, and indeed, I see this bug in item status but not in check in.

Kathy Lussier (klussier) wrote :

Ugh, yeah. I'll update the description. Thanks Andrea!

summary: - web client: Scanning non-existent items at check in fails without
+ web client: Scanning non-existent items at item status fails without
feedback to the user
description: updated
Jennifer Pringle (jpringle-u) wrote :

When I scan a non-existent barcode into Item Status on 2.12.1. I get a a big red "Item Not Found" across the screen and I hear the da da noise (not sure how else to describe it) so the user is getting some feedback now. Are we still wanting the red alert/submarine siren and the "XXX was either mis-scanned or is not catalogued" message as well?

Kathy Lussier (klussier) wrote :

Hi Jennifer,

This bug only occurs in master. It's a regression caused by code that added column picker options in Item Status, which was never backported to 2.12. I'll update the original description to make it clear where the problem is occurring.

As a sidenote, if we cannot get a fix for this by the 3.0 release, we should probably discuss whether we want to revert the code that added the column picker options. It's very important to have those options, but one might argue that failed scans without feedback are more of a problem.

description: updated
Changed in evergreen:
assignee: nobody → Skye Howard (showard1110)
Kathy Lussier (klussier) on 2017-08-03
tags: added: silentfailure
Kathy Lussier (klussier) on 2017-08-10
Changed in evergreen:
importance: Medium → High
Cesar V (cesardv) wrote :

Just FYI I have a patch/fix for this but it's based on a branch that has yet to hit master (see comment # on bug 1685929)... so in an effort to reduce conflicts and extra merge work for whomever gets to merge that, it should wait until that branch hits master.

Branch link to follow.

Cesar V (cesardv) on 2017-08-18
tags: added: pullrequest
Changed in evergreen:
assignee: Skye Howard (showard1110) → nobody
Andrea Neiman (aneiman) on 2017-08-30
Changed in evergreen:
milestone: none → 3.0-alpha
Galen Charlton (gmc) on 2017-08-30
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Tested and pushed to master. Thanks, Cesar!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers