Upgrade script 1026 transposes metabib_field.id

Bug #1680554 reported by Martha Driscoll on 2017-04-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Release 2.12.0 upgrade script 1026.data.subject_browse.sql transposes config.metabib_field.id when setting browse to false:

SET browse_field = FALSE
WHERE field_class = 'subject' AND name = 'geographic'
AND id = 13; (this should be 11)
UPDATE config.metabib_field
SET browse_field = FALSE
WHERE field_class = 'subject' AND name = 'temporal'
AND id = 11; (this should be 13)

And again when updating authority.control_set_bib_field_metabib_field_map:

UPDATE authority.control_set_bib_field_metabib_field_map
SET metabib_field = 35
WHERE metabib_field = 13; (this should be 11)
UPDATE authority.control_set_bib_field_metabib_field_map
SET metabib_field = 36
WHERE metabib_field = 11; (this should be 13)

The version upgrade script 2.11.3-2.12.0-upgrade-db.sql is similarly incorrect.

The scripts run without error. I happened to notice this because we have some custom indexes using ID's 34, 35, 36 and I had to go into the script to update with our ID numbers and noticed the mismatch.

Galen Charlton (gmc) on 2017-04-06
Changed in evergreen:
status: New → Confirmed
milestone: none → 2.12.1
Galen Charlton (gmc) wrote :

A patch is available at the tip of the user/gmcharlt/lp1680554_fix_browse_def_ids branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1680554_fix_browse_def_ids

tags: added: pullrequest
Kathy Lussier (klussier) wrote :

Thank you Martha and Galen! Merged to master and release 2.12

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers