Format dropdown in searchbar does not work correctly after advanced search with format limiters

Bug #1679309 reported by Jeff Davis
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Medium
Unassigned

Bug Description

Evergreen 2.12

When the Search Formats filter is made available on the advanced search page, any format limiters selected there will override any filters selected in subsequent searches via the searchbar.

Steps to reproduce:

1. Enable the Search Formats filter on the advanced search page by adding the following line to the search.adv_filter block in config.tt2:

{adv_label => l("Format"), adv_attr => "search_format", id => 'adv_selector_search_format'},

2. Go to the advanced search page and do a search, selecting one of the limiters from the Search Formats filter.

3. On the search results page, use the searchbar to enter a new search, selecting a different format limiter from the format dropdown. Your newly-selected format will be ignored; instead, the limiters from your previous search persist, overriding whatever new selection you've made. The correct behavior here would be for any new format selected via the format filter in the searchbar to override any persisted format limiters.

This looks like a consequence of the changes for bug 1005040. A fix for this issue may be related to fixes for bug 1677902 and bug 1669563 (display of search format limiters in results sidebar).

Tags: pullrequest
Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

Branch user/jeffdavis/lp1679309-adv-search-format-filter-persistence of the working repo fixes the issue in the simplest way possible: by suppressing advanced search format limiters in the searchbar altogether. I'm not sure if this is the best approach, depending on what happens with bug 1669563.

Kathy Lussier (klussier)
Changed in evergreen:
status: New → Triaged
milestone: none → 2.12.1
Revision history for this message
Kathy Lussier (klussier) wrote :

Thanks Jeff! I'm on the fence with this solution. The user can select new formats when launching a new search in the searchbar, which is nice, but the behavior is different from what we see with all the other advanced search limiters.

Mike and I discussed a solution at the conference where we would disable the format selector if there are two or more search format limiters on the search results page. The behavior of the advanced search limiters is consistent in this case, but it could be annoying for users. I see pros and cons to both approaches.

I'm going to work on a branch for the other approach to see how it works.

Changed in evergreen:
milestone: 2.12.1 → 2.12.2
Revision history for this message
Kathy Lussier (klussier) wrote :

After looking at this issue further and discussing it with some colleagues, I'm going to take back what I said in comment #2. I think this one is the better approach. I'll review it at the same time that I'm looking at bug 1669563 to make sure they work well together.

tags: added: pullrequest
Changed in evergreen:
milestone: 2.12.2 → 2.12.3
Revision history for this message
Kathy Lussier (klussier) wrote :

Thanks Jeff!

I haven't had the tuits to make much progress on bug 1669563, but I think this works well on its own. Merged to master and backported to 2.12.

Changed in evergreen:
status: Triaged → Fix Committed
importance: Undecided → Medium
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.