Web Client: Navigating from View Holds - Opac View - View Holds duplicates hold list

Bug #1669907 reported by Michele Morgan on 2017-03-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Evergreen 2.11+ web client

When viewing a record with holds, if the staff user navigates from View Holds to Opac View and back to View Holds, the list of holds is duplicated, giving the appearance of twice the number of holds than actually exist.

Here's a quick screencast illustrating the behavior:

https://www.screencast.com/t/42wdGITi

Cesar V (cesardv) on 2017-06-27
tags: added: needstest
tags: added: pullrequest
Terran McCanna (tmccanna) wrote :

I'll test this during bug squashing week

Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
Terran McCanna (tmccanna) wrote :

Works for me!

I have tested this code and consent to signing off on it with my name, Terran McCanna and my email address, <email address hidden>.

tags: added: signedoff
removed: needstest
Changed in evergreen:
assignee: Terran McCanna (tmccanna) → nobody
status: New → Confirmed
Galen Charlton (gmc) on 2017-07-19
Changed in evergreen:
milestone: none → 2.12.4
importance: Undecided → Medium
Galen Charlton (gmc) wrote :

Pushed to master and rel_2_12. Thanks, Cesar and Terran.

I note that the underlying cause of the bug is that the grid provider.get() is getting called two times in quick succession when the user switch to the View Holds tab. That's, at minimum, inefficient, since the same set of holds is getting fetched twice. I'll open a separate bug.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers