unbreak stock full overlay merge profile

Bug #1663663 reported by Galen Charlton on 2017-02-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Due to copy-and-pastitis, the patch for bug 1447746 inadvertently broke the definition of the stock Full Overlay merge profile by setting replace_spec to '901c' instead of preserve_spec. The effect is that the Full Overlay profile acts identically to Match-Only Merge except that it also updates the bib source.

Evergreen 2.11 (new installations)

Galen Charlton (gmc) on 2017-02-10
Changed in evergreen:
milestone: none → 2.11.3
importance: Undecided → Medium
Galen Charlton (gmc) wrote :

A two-patch series is available in the user/gmcharlt/lp1663663_fix_full_overlay_profile branch in the working/Evergreen repository

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1663663_fix_full_overlay_profile

tags: added: cataloging pullrequest regression vandelay
Kathy Lussier (klussier) wrote :

Works for me. Thank you Galen!

Merged to master and backported to release 2.11.

Changed in evergreen:
status: New → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers