Web client: Edit Due Date form does not submit

Bug #1657466 reported by Kathy Lussier on 2017-01-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.10
Medium
Unassigned
2.11
Medium
Unassigned

Bug Description

This issue was originally reported in bug 1437109, but I'm breaking it into its own bug since it's unrelated to the due date calculation.

On the patron Items Out screen, if you click to Edit a due date, the Edit Due Date form will not Submit. I see the following in the browser console when I try to submit an edited due date:

TypeError: Cannot read property 'getMinutes' of undefined
    at b.$scope.ok (items_out.js:280)
    at fn (eval at compile (angular.js:15033), <anonymous>:4:290)
    at b (angular.js:16123)
    at e (angular.js:26490)
    at b.$eval (angular.js:17913)
    at b.$apply (angular.js:18013)
    at HTMLFormElement.<anonymous> (angular.js:26495)
    at HTMLFormElement.dispatch (jquery.min.js:3)
    at HTMLFormElement.r.handle (jquery.min.js:3)

I'm immediately marking this one as confirmed since it was reported by Terran on the other bug.

Kyle Huckins (khuckins) wrote :

Fortunately this looks like a quick fix. There are references to $scope.args.date. Problem being that $scope.args doesn't have date, it has due_date. I'll push up a fix shortly.

Changed in evergreen:
assignee: nobody → Kyle Huckins (khuckins)
Kyle Huckins (khuckins) wrote :
Changed in evergreen:
assignee: Kyle Huckins (khuckins) → nobody
tags: added: pullrequest
Kyle Huckins (khuckins) wrote :

Reviewing the changes made in the related branch(1437109) by Victoria, it appears that the change was very similar to this one, just on a much older version of the codebase. However, this won't entirely fix bug 1437109, due to the hourly change requirement.

Kathy Lussier (klussier) on 2017-01-27
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

Works for me. I signed off on the branch and merged it to master, release 2.11 and release 2.10.

Thanks Kyle!

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
milestone: 2.next → 2.12-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers