action.aged_circulation needs a parent_circ index

Bug #1657241 reported by Chris Sharp on 2017-01-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Critical
Unassigned

Bug Description

The changes in bug 1497335 introduced a feature to display aged circulation information to the end user. When going live on Evergreen 2.11.1 in PINES, we discovered that the queries created by the action.all_circ_chain() DB function were unoptimized and caused extreme database slowness and instability since the UI using that feature is accessed frequently by end users. Thanks to Bill Erickson's suggestion, we found that adding an index for parent_circ on action.aged_circulation resolved the problem.

Evergreen 2.11.1
OpenSRF 2.4.1
PostgreSQL 9.4
Ubuntu 14.04 LTS

Chris Sharp (chrissharp123) wrote :
tags: added: pullrequest
Changed in evergreen:
status: New → Confirmed
importance: Undecided → High
importance: High → Critical
Bill Erickson (berick) on 2017-01-17
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
milestone: none → 2.11.2
Bill Erickson (berick) wrote :

Tested and merged to 2.11 and master. Thanks, Chris.

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers