Makefile, Makefile.in, Makefile.am appear in /openils/var/web

Bug #1656549 reported by Jason Stephenson on 2017-01-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Evergreen Version: 2.10.7 (Reportedly also affects 2.9.x and 2.11.1.)
OpenSRF Version: N/A
Postgres Version: N/A
O/S Versions: Ubuntu 14.04 (Trusty Tahr), Ubuntu 16.04 (Xenial Xerus), Debian 7 (Wheezy), Debian 8 (Jessie)

After doing make install, Makefile, Makefile.in, and Makefile.am appear in the $PREFIX/var/web directory, usually /openils/var/web.

I should add that the expected behavior is that they not appear there.

description: updated
Jason Stephenson (jstephenson) wrote :

Looks like this happens because of line 51 in Open-ILS/web/Makefile.am.

Here's a working branch that inserts a new line 52 into that file to remove the Makefiles from the WEBDIR after the copy that puts them there:

user/dyrcona/lp1656549-var-web-Makefile-delete

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1656549-var-web-Makefile-delete

I have built it on Ubuntu 16.04 (Xenial Xerus) and it works as expected. I see no reason that it would not work on other releases.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.next
Ben Shum (bshum) wrote :

Works fine for me. Pushed to master only as a new change for next release.

Changed in evergreen:
milestone: 2.next → 2.12-beta
status: New → Fix Committed
importance: Undecided → Wishlist
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers